]> git.pld-linux.org Git - packages/dopewars.git/blame - dopewars.spec
- fixed locale fix
[packages/dopewars.git] / dopewars.spec
CommitLineData
a2d6b0bc 1#
2# Conditional build:
7fd7c735 3%bcond_without gtk # don't build GTK+ client
4%bcond_without curses # don't build curses client
5%bcond_without sdl # don't use sdl sound output
6%bcond_without esd # don't use esd sound output
541c6ec4 7#
a2d6b0bc 8Summary: Drug dealing game
58bdf6c1 9Summary(pl.UTF-8): Gra polegająca na handlowaniu narkotykami
a2d6b0bc 10Name: dopewars
65e1df3e 11Version: 1.5.12
3d8a1fec 12Release: 3
a2d6b0bc 13License: GPL
14Group: Applications/Games
15c71c6c 15Source0: http://dl.sourceforge.net/dopewars/%{name}-%{version}.tar.gz
65e1df3e 16# Source0-md5: debf749de9053dc2fb2e74c37ae06206
1599395c 17Patch0: %{name}-desktop.patch
65e1df3e 18Patch1: %{name}-scoredir.patch
a2d6b0bc 19URL: http://dopewars.sourceforge.net/
1dcaf906 20%{?with_sdl:BuildRequires: SDL-devel >= 1.0.0}
21%{?with_sdl:BuildRequires: SDL_mixer-devel}
a2d6b0bc 22BuildRequires: autoconf
23BuildRequires: automake
1dcaf906 24%{?with_esd:BuildRequires: esound-devel >= 0.0.20}
559ad620 25BuildRequires: gettext-devel
338a458c 26BuildRequires: glib2-devel >= 2.0.0
559ad620 27BuildRequires: gtk+-devel
99c46b26 28%{?with_gtk:BuildRequires: gtk+2-devel >= 1:2.0.0}
1dcaf906 29%{?with_curses:BuildRequires: ncurses-devel}
559ad620 30BuildRequires: pkgconfig
a2d6b0bc 31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34Based on John E. Dell's old Drug Wars game, dopewars is a simulation
35of an imaginary drug market. dopewars is an All-American game which
36features buying, selling, and trying to get past the cops!
37
38The first thing you need to do is pay off your debt to the Loan Shark.
39After that, your goal is to make as much money as possible (and stay
40alive)! You have one month of game time to make your fortune.
41
541c6ec4 42dopewars supports multiple players via TCP/IP. Chatting to and
a2d6b0bc 43fighting with other players (computer or human) is supported; check
44the command line switches (via dopewars -h) for further information.
45
4084fd5a
JR
46%description -l pl.UTF-8
47dopewars jest symulacją wyimaginowanego narkotykowego rynku, bazującą
541c6ec4 48na starej grze Drug Wars autorstwa Johna E. Della. Jest to gra w
4084fd5a 49amerykańskim stylu polegająca na kupowaniu, sprzedawaniu i omijaniu
541c6ec4 50policji!
a2d6b0bc 51
4084fd5a
JR
52Pierwszą rzeczą jaką trzeba zrobić jest spłacenie długu. Potem celem
53jest zdobycie jak największej ilości pieniędzy (i przeżycie)! Gracz ma
54jeden miesiąc gry na zdobycie fortuny.
a2d6b0bc 55
4084fd5a
JR
56W dopewars można grać z wieloma graczami poprzez TCP/IP. Można także z
57nimi rozmawiać i walczyć; więcej informacji w opisie parametrów linii
58poleceń (pokaże je dopewars -h).
a2d6b0bc 59
60%prep
61%setup -q
1599395c 62%patch0 -p1
65e1df3e 63%patch1 -p1
a2d6b0bc 64
65%build
66rm -f missing
67%{__aclocal}
68%{__autoconf}
69%{__automake}
70%configure \
541c6ec4
JB
71 --enable-plugins \
72 --enable-networking \
1dcaf906 73 %{?with_esd:--with-esd} \
74 %{?with_sdl:--with-sdl} \
75 %{?with_curses:--enable-curses-client} \
76 %{?with_gtk:--enable-gui-client} \
77 %{?with_gtk:--enable-gui-server}
a2d6b0bc 78
c01b5690 79%{__make} \
bfcf19a4 80 CFLAGS="%{rpmcflags} -Wall -I/usr/include/ncurses"
a2d6b0bc 81
82%install
83rm -rf $RPM_BUILD_ROOT
1599395c 84install -d $RPM_BUILD_ROOT%{_desktopdir}
a2d6b0bc 85
a421f811 86%{__make} install \
65e1df3e 87 SCOREDIR=$RPM_BUILD_ROOT/var/games/dopewars \
a421f811 88 DESTDIR=${RPM_BUILD_ROOT}
a2d6b0bc 89
90# I think this could be done somehow prettier
1599395c 91mv $RPM_BUILD_ROOT%{_datadir}/gnome/apps/Games/dopewars.desktop $RPM_BUILD_ROOT%{_desktopdir}
a2d6b0bc 92
93rm -f doc/help/Makefile*
94
c3ca080c 95# es_ES.po seems to be newer than es.po
559ad620 96mv -f $RPM_BUILD_ROOT%{_datadir}/locale/es_ES/LC_MESSAGES/* \
97 $RPM_BUILD_ROOT%{_datadir}/locale/es/LC_MESSAGES/
98rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/es_ES
c3ca080c 99
a2d6b0bc 100%find_lang %{name}
101
102%clean
541c6ec4 103rm -rf $RPM_BUILD_ROOT
a2d6b0bc 104
93d50913
AG
105%triggerpostun -- dopewars < 1.5.12-0.1
106# move scorefile
107mv -f %{_datadir}/dopewars.sco.rpmsave /var/games/dopewars/dopewars.sco
108chown root:games /var/games/dopewars/dopewars.sco
109chmod 660 /var/games/dopewars/dopewars.sco
110%{_bindir}/dopewars -C /var/games/dopewars/dopewars.sco
a2d6b0bc 111
112%files -f %{name}.lang
113%defattr(644,root,root,755)
114%doc ChangeLog LICENCE README doc/{*.html,help}
93d50913 115%attr(2755,root,games) %{_bindir}/dopewars
65e1df3e 116%attr(770,root,games) /var/games/dopewars
a2d6b0bc 117%{_mandir}/man6/*
118%{_libdir}/%{name}
1adb5e03 119%{_desktopdir}/*.desktop
541c6ec4 120%{_pixmapsdir}/*
a2d6b0bc 121%{_datadir}/%{name}
This page took 0.096974 seconds and 4 git commands to generate.