]> git.pld-linux.org Git - packages/dnprogs.git/blame - dnprogs.spec
- tabs in preamble
[packages/dnprogs.git] / dnprogs.spec
CommitLineData
19c3276c 1%define dnet_major 1
2%define dnet_version %{dnet_major}.2
e4deb272 3%define dap_major 2
4%define dap_version %{dap_major}.23
19c3276c 5%define dnprogs_version %{dap_version}
239180c6 6Summary: DECnet tools and libraries
21bb81d2 7Summary(pl.UTF-8): Narzędzia i biblioteki DECnet
239180c6 8Name: dnprogs
42ec118e 9Version: %{dnprogs_version}
e4deb272 10Release: 0.1
42ec118e 11License: GPL
12Group: Networking/Utilities
e4deb272 13Source0: http://dl.sourceforge.net/linux-decnet/%{name}-%{version}.tar.gz
14# Source0-md5: 666e1479f60f7f0fe3bf8da3abab98bd
c6ef0d68 15URL: http://linux-decnet.sourceforge.net/
c6ef0d68
JB
16PreReq: rc-scripts
17Requires(post,preun): /sbin/chkconfig
18Requires(post): /sbin/ldconfig
239180c6 19ExclusiveOS: Linux
c25b4b72 20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19c3276c 21
22%description
23DECnet programs for Linux.
24
42ec118e 25These tools are the application layer interface for DECnet on Linux
26systems. They provide file/terminal access facilities between OpenVMS
27and Linux and remote execution of commands.
19c3276c 28
42ec118e 29To use them you will need to have DECnet built into your kernel. See
30http://linux.dreamtime.org/decnet/ to get the kernel patch and
19c3276c 31instructions on how to apply it.
8c74f4ce 32
1f826f11
JR
33%description -l pl.UTF-8
34Programy DECnet dla Linuksa. Narzędzia te stanowią warstwę interfejsu
35aplikacji dla DECnetu na systemach linuksowych. Udostępniają pewne
36ułatwienia w dostępie terminalowym i plikowym między OpenVMS-em a
37Linuksem oraz zdalnym wykonywaniem poleceń. Aby ich użyć trzeba mieć
38wbudowaną w jądro obsługę DECnetu. Łatę oraz instrukcje dotyczące jej
39instalacji można uzyskać na stronie:
a4726999 40http://linux.dreamtime.org/decnet/.
41
8c74f4ce 42%prep
42ec118e 43%setup -q
8c74f4ce
AM
44
45find . -type f -name '*~' -print0 | xargs -0 rm -f
46
47%build
33085a3a 48%{__make} DFLAGS="%{rpmcflags}" LIBCRYPT=-lcrypt SHADOWDEFS=-DSHADOW_PWD \
42ec118e 49 prefix=%{_prefix} libprefix=%{_prefix} sysconfprefix=
8c74f4ce
AM
50
51%install
52rm -rf $RPM_BUILD_ROOT
42ec118e 53install -d $RPM_BUILD_ROOT
8c74f4ce
AM
54chmod go= $RPM_BUILD_ROOT
55
42ec118e 56install -d $RPM_BUILD_ROOT/{etc/rc.d/{init,rc{0,1,2,3,4,5,6}}.d,lib,sbin}
ff6f4957 57%{__make} prefix=$RPM_BUILD_ROOT%{_prefix} libprefix=$RPM_BUILD_ROOT%{_prefix} \
8c74f4ce
AM
58 sysconfprefix=$RPM_BUILD_ROOT install
59
60rm -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so
61rm -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so.%{dnet_major}
62mv -f $RPM_BUILD_ROOT%{_libdir}/libdnet.so.%{dnet_version} \
63 $RPM_BUILD_ROOT/lib/libdnet.so.%{dnet_version}
33085a3a 64ln -sf libdnet.so.%{dnet_version} \
8c74f4ce 65 $RPM_BUILD_ROOT/lib/libdnet.so.%{dnet_major}
33085a3a 66ln -sf ../../lib/libdnet.so.%{dnet_major} \
8c74f4ce
AM
67 $RPM_BUILD_ROOT%{_libdir}/libdnet.so
68
69mv -f $RPM_BUILD_ROOT%{_sbindir}/startnet $RPM_BUILD_ROOT/sbin/startnet
70
42ec118e 71touch $RPM_BUILD_ROOT%{_sysconfdir}/decnet.proxy
8c74f4ce 72
42ec118e 73install scripts/decnet.sh $RPM_BUILD_ROOT/etc/rc.d/init.d/decnet
8c74f4ce
AM
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
567d906b 78%post
405c370d 79/sbin/chkconfig --add decnet
8c74f4ce
AM
80/sbin/ldconfig
81
82%postun
83/sbin/ldconfig
c6ef0d68
JB
84if [ "$1" = "0" ]; then
85 /sbin/chkconfig --del decnet
405c370d 86fi
8c74f4ce 87
c6ef0d68
JB
88%postun -p /sbin/ldconfig
89
8c74f4ce
AM
90%files
91%defattr(644,root,root,755)
92%doc Documentation/* README NEWS dnprogs.lsm
42ec118e 93%config(noreplace) %{_sysconfdir}/decnet.conf
94%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/decnet.proxy
eae33582 95%attr(754,root,root) /etc/rc.d/init.d/decnet
239180c6 96%attr(755,root,root) /lib/libdnet.so.%{dnet_major}
8c74f4ce 97%attr(755,root,root) /lib/libdnet.so.%{dnet_version}
8c74f4ce 98%attr(755,root,root) /sbin/startnet
8c74f4ce
AM
99%attr(755,root,root) %{_bindir}/dncopy
100%attr(755,root,root) %{_bindir}/dndel
101%attr(755,root,root) %{_bindir}/dndir
102%attr(755,root,root) %{_bindir}/dnping
239180c6 103%attr(755,root,root) %{_bindir}/dnprint
8c74f4ce
AM
104%attr(755,root,root) %{_bindir}/dnsubmit
105%attr(755,root,root) %{_bindir}/dntask
239180c6 106%attr(755,root,root) %{_bindir}/dntype
8c74f4ce
AM
107%attr(755,root,root) %{_bindir}/phone
108%attr(755,root,root) %{_bindir}/sethost
8c74f4ce 109%{_includedir}/netdnet
8c74f4ce 110%{_libdir}/libdnet.a
239180c6 111%attr(755,root,root) %{_libdir}/libdnet.so
8c74f4ce 112%{_libdir}/libdap.a
239180c6
JB
113%attr(755,root,root) %{_libdir}/libdap.so
114%attr(755,root,root) %{_libdir}/libdap.so.%{dap_major}
8c74f4ce 115%attr(755,root,root) %{_libdir}/libdap.so.%{dap_version}
33085a3a
JB
116%{_mandir}/man1/ctermd.1*
117%{_mandir}/man1/dncopy.1*
118%{_mandir}/man1/dndel.1*
119%{_mandir}/man1/dndir.1*
120%{_mandir}/man1/dnmirror.1*
8583d5f0 121#%%{_mandir}/man1/dnmount.1*
33085a3a
JB
122%{_mandir}/man1/dnping.1*
123%{_mandir}/man1/dnprint.1*
124%{_mandir}/man1/dnsubmit.1*
125%{_mandir}/man1/dntask.1*
126%{_mandir}/man1/dntype.1*
127%{_mandir}/man1/phone.1*
128%{_mandir}/man1/sethost.1*
129%{_mandir}/man1/startnet.1*
33085a3a
JB
130%{_mandir}/man3/dnet_addr.3*
131%{_mandir}/man3/dnet_conn.3*
132%{_mandir}/man3/dnet_htoa.3*
133%{_mandir}/man3/dnet_ntoa.3*
134%{_mandir}/man3/getnodeadd.3*
135%{_mandir}/man3/getnodebyaddr.3*
136%{_mandir}/man3/getnodebyname.3*
137%{_mandir}/man3/libdnet.3*
138%{_mandir}/man3/setnodeent.3*
33085a3a
JB
139%{_mandir}/man5/decnet.conf.5*
140%{_mandir}/man5/decnet.proxy.5*
33085a3a
JB
141%{_mandir}/man8/fal.8*
142%{_mandir}/man8/phoned.8*
8c74f4ce
AM
143%attr(755,root,root) %{_sbindir}/ctermd
144%attr(755,root,root) %{_sbindir}/dnmirror
145%attr(755,root,root) %{_sbindir}/fal
146%attr(755,root,root) %{_sbindir}/phoned
147%attr(755,root,root) %{_sbindir}/sendvmsmail
148%attr(755,root,root) %{_sbindir}/vmsmaild
This page took 0.321829 seconds and 4 git commands to generate.