]> git.pld-linux.org Git - packages/dehydrated.git/blame - dehydrated.spec
do not obsolete letsencrypt.sh
[packages/dehydrated.git] / dehydrated.spec
CommitLineData
1780cc1f 1Summary: letsencrypt/acme client implemented as a shell-script
0b9f695c
ER
2Name: dehydrated
3Version: 0.3.1
de4255b2 4Release: 1
1780cc1f
ER
5License: MIT
6Group: Applications/Networking
0b9f695c
ER
7Source0: https://github.com/lukas2511/dehydrated/archive/v%{version}/%{name}-%{version}.tar.gz
8# Source0-md5: 7a3b92b963da6469c4a53f051d6efa24
eb6aa75d
ER
9Source1: apache.conf
10Source2: lighttpd.conf
aebe760f 11Source3: nginx.conf
8f670f9f 12Source4: domains.txt
5765eca7 13Source5: hook.sh
a0535a11 14Source6: crontab
f5fc6721 15Patch0: pld.patch
0b9f695c 16URL: https://github.com/lukas2511/dehydrated
1780cc1f 17BuildRequires: rpmbuild(macros) >= 1.713
a0535a11 18Requires: crondaemon
1780cc1f
ER
19Requires: curl
20Requires: grep
21Requires: mktemp
60120665 22Requires: openssl-tools
1780cc1f 23Requires: sed
eb6aa75d 24Requires: webapps
9f9f4d8c
ER
25Suggests: webserver(access)
26Suggests: webserver(alias)
1780cc1f
ER
27BuildArch: noarch
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
eb6aa75d
ER
30%define _webapps /etc/webapps
31%define _webapp %{name}
32%define _sysconfdir %{_webapps}/%{_webapp}
33%define _appdir %{_datadir}/%{_webapp}
34
1780cc1f
ER
35%description
36This is a client for signing certificates with an ACME-server
37(currently only provided by letsencrypt) implemented as a relatively
38simple bash-script.
39
40Current features:
41- Signing of a list of domains
42- Signing of a CSR
43- Renewal if a certificate is about to expire or SAN (subdomains)
44 changed
45- Certificate revocation
46
47%prep
48%setup -q
f5fc6721 49%patch0 -p1
1780cc1f
ER
50
51%install
52rm -rf $RPM_BUILD_ROOT
f19ccd97 53install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/certs,/etc/cron.d} \
e354c9b6 54 $RPM_BUILD_ROOT/var/lib/%{name}/{accounts,acme-challenge,certs}
eb6aa75d 55
0b9f695c 56install -p %{name} $RPM_BUILD_ROOT%{_sbindir}
eb6aa75d
ER
57cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
58cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
aebe760f 59cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/nginx.conf
3ec257e0 60cp -p docs/examples/config $RPM_BUILD_ROOT%{_sysconfdir}
8f670f9f 61cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
0b9f695c 62cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/cron.d/%{name}
5765eca7 63install -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}
eb6aa75d 64cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
1780cc1f
ER
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
eb6aa75d
ER
69%triggerin -- apache1 < 1.3.37-3, apache1-base
70%webapp_register apache %{_webapp}
71
72%triggerun -- apache1 < 1.3.37-3, apache1-base
73%webapp_unregister apache %{_webapp}
74
75%triggerin -- apache < 2.2.0, apache-base
76%webapp_register httpd %{_webapp}
77
78%triggerun -- apache < 2.2.0, apache-base
79%webapp_unregister httpd %{_webapp}
80
81%triggerin -- lighttpd
82%webapp_register lighttpd %{_webapp}
83
84%triggerun -- lighttpd
85%webapp_unregister lighttpd %{_webapp}
86
aebe760f
ER
87%triggerin -- nginx
88%webapp_register nginx %{_webapp}
89
90%triggerun -- nginx
91%webapp_unregister nginx %{_webapp}
92
1780cc1f
ER
93%files
94%defattr(644,root,root,755)
95%doc README.md CHANGELOG LICENSE
0b9f695c 96%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}
7410a329 97%dir %attr(750,root,http) %{_sysconfdir}
eb6aa75d
ER
98%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
99%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
100%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
aebe760f 101%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/nginx.conf
7693646e 102%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config
8f670f9f 103%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
5765eca7 104%attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook.sh
0b9f695c 105%attr(755,root,root) %{_sbindir}/%{name}
f19ccd97
ER
106%dir %attr(751,root,root) /var/lib/%{name}
107%dir %attr(700,root,root) /var/lib/%{name}/accounts
e354c9b6 108%dir %attr(700,root,root) /var/lib/%{name}/certs
2e509387 109# challenges written here, need to be readable by webserver
f19ccd97 110%dir %attr(751,root,root) /var/lib/%{name}/acme-challenge
This page took 0.078981 seconds and 4 git commands to generate.