]> git.pld-linux.org Git - packages/ddd.git/blame - ddd.spec
- updated to 3.1.2.
[packages/ddd.git] / ddd.spec
CommitLineData
22b41ee6 1Summary: X interface to the GDB, DBX and XDB debuggers
2Name: ddd
fdbb4315 3Version: 3.1.2
22b41ee6 4Release: 1
5Source0: ftp://ftp.ips.cs.tu-bs.de/pub/local/softech/ddd/src/%{name}-%{version}.tar.gz
6Copyright: GPL
7Group: Development/Debuggers
8Icon: ddd.xpm
9URL: http://www.cs.tu-bs.de/softech/ddd/
10Buildroot: /tmp/%{name}-%{version}-root
11
12%description
13The Data Display Debugger (DDD) is a common graphical user interface for
14GDB, DBX, and XDB, the popular UNIX debuggers. Besides ``classical''
15front-end features such as viewing source texts, DDD provides a graphical
16data display, where data structures are displayed as graphs. A simple mouse
17click dereferences pointers or views structure contents, updated each time
18the program stops. Using DDD, you can reason about your application by
19viewing its data, not just by viewing it execute lines of source code.
20Other DDD features include: debugging of programs written in C, C++, Ada,
21Fortran, Java, Pascal, Modula-2, or Modula-3; machine-level debugging;
22hypertext source navigation and lookup; breakpoint, backtrace, and history
23editors; preferences and settings editors; program execution in terminal
24emulator window; debugging on remote host; on-line manual; interactive help
25on the Motif user interface; GDB/DBX/XDB command-line interface with full
26editing, history, search, and completion capabilities. DDD has been
27designed to compete with well-known commercial debuggers
28
29%package python
30Summary: X interface to the GDB, DBX and XDB debuggers - The python debugger
31Group: Development/Debuggers
32Requires: %{name} = %{version}
33
34%description python
35Data Display Debugger - python debugger.
36
37%prep
38%setup -q
39
40%build
41CFLAGS="$RPM_OPT_FLAGS" CXXFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
42./configure \
43 --with-motif \
44 --prefix=/usr/X11R6
45make CXXOPT="-DNDEBUG $RPM_OPT_FLAGS"
46
47%install
48rm -rf $RPM_BUILD_ROOT
49install -d $RPM_BUILD_ROOT/{etc/X11/wmconfig,usr/{lib/python-1.5,X11R6/lib/X11/app-defaults}}
50
51make install prefix=$RPM_BUILD_ROOT/usr/X11R6
52
53install pydb/pydb.py $RPM_BUILD_ROOT/usr/X11R6/bin
54install pydb/{pydbcmd,pydbsupt}.py $RPM_BUILD_ROOT/usr/lib/python-1.5
55
56install ddd/Ddd $RPM_BUILD_ROOT/usr/X11R6/lib/X11/app-defaults
57gzip -9nf $RPM_BUILD_ROOT/usr/X11R6/man/man1/*
58
59cat > $RPM_BUILD_ROOT/etc/X11/wmconfig/ddd <<EOF
60ddd name "DDD"
61ddd description "Data Display Debuger"
62ddd exec "/usr/X11R6/bin/ddd"
63ddd group "Development"
64EOF
65
66cat > $RPM_BUILD_ROOT/etc/X11/wmconfig/ddd-python <<EOF
67ddd name "DDD for python"
68ddd description "Data Display Debuger - python"
69ddd exec "/usr/X11R6/bin/ddd --pydb"
70ddd group "Development"
71EOF
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%files
77%defattr(644, root, root, 755)
78%doc DOCS ANNOUNCE BUGS ChangeLog* NEWS* OPENBUGS PROBLEMS README TIPS TODO doc/sample.dddinit
79/etc/X11/wmconfig/ddd
80%attr(755, root, root) /usr/X11R6/bin/*
81%attr(644, root, man) /usr/X11R6/man/man1/*
82/usr/X11R6/lib/X11/app-defaults/Ddd
83
84%files python
85%defattr(644, root, root, 755)
86/etc/X11/wmconfig/ddd-python
87%attr(755, root, root) /usr/X11R6/bin/pydb.py
88/usr/lib/python-1.5/*
89
90%changelog
91