]> git.pld-linux.org Git - packages/dar.git/blame - dar.spec
- Spec file written from scratch.
[packages/dar.git] / dar.spec
CommitLineData
fbe89be6 1Summary: dar makes backup of a directory tree and files
2Name: dar
3Version: 1.1.0
4Release: 1
5License: GPL
6Group: Applications
7Source0: http://dar.linux.free.fr/%{name}-%{version}.tar.gz
8URL: http://dar.linux.free.fr/
9BuildRequires: glibc-static
10BuildRequires: zlib-static
11BuildRequires: libstdc++-static
12BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14%description
15
16dar is a shell command, that makes backup of a directory tree and
17files.
18
19FILTERS: dar is able to backup from total file system to a single
20file. Additionally a mechanism of filters permits, based on the
21filename, to exclude or include some files while backing up or
22restoring a directory tree. In the other side, a secondary filter
23mechanism permits to exclude some branches of a directory tree, or to
24only include some branches.
25
26DIFFERENTIAL BACKUP: When making a backup with dar, you have the
27possibility to make a full backup or a differential backup. A full
28backup, as expected makes backup of all files as specified on the
29command line (with or without filters). Instead, a differential
30backup, (over filter mechanism), saves only files that have changed
31since a given reference backup. Additionally, files that existed in
32the reference backup and which do no more exist at the time of the
33differential backup are recorded in the backup. At recovery time,
34(unless you deactivate it), restoring a differential backup will
35update changed files and new files, but also remove files that have
36been recorded as deleted. Note that the reference backup can be a full
37backup or another differential backup. This way you can make a first
38full backup, then many differential backup, each taking as reference
39the last backup made.
40
41SLICES: Dar stands for Disk ARchive. From the beginning it was
42designed to be able to split an archive over several removable media
43whatever their number is and whatever their size is. Thus dar is able
44to save over old floppy disk, CD-R, DVD-R, CD-RW, DVD-RW, Zip, Jazz,
45etc... Dar is not concerned by un/mounting a removable medium, instead
46it is independent of hardware. Given the size, it will split the
47archive in several files (called SLICES), eventually pausing before
48creating the next one, allowing this way, the user to un/mount a
49medium, burn the file on CD-R, send it by email (if your mail system
50does not allow huge file in emails, dar can help you here also). By
51default, (no size specified), dar will make one slice whatever its
52size is. Additionally, the size of the first slice can be specified
53separately, if for example you want first to fulfil a partially filled
54disk before starting using empty ones. Last, at restoration time, dar
55will just pause and prompt the user asking a slice only if it is
56missing.
57
58COMPRESSION: last, dar can use compression. By default no compression
59is used. Actually only gzip algorithm is implemented, but some room
60has been done for bzip2 and any other compression algorithm. Note
61that, compression is made before slices, which means that using
62compression with slices, will not make slices smaller, but will
63probably make less slices in the backup.
64
65DIRECT ACCESS: even using compression dar has not to read the whole
66backup to extract one file. This way if you just want to restore one
67file from a huge backup, the process will be much faster than using
68tar. Dar first reads the catalogue (i.e. the contents of the backup),
69then it goes directly to the location of the saved file(s) you want to
70restore and proceed to restoration. In particular using slices dar
71will ask only for the slice(s) containing the file(s) to restore.
72
73HARD LINK CONSIDERATION: hard links are now properly saved. They are
74properly restored if possible. If for example restoring across a
75mounted filesystem, hard linking will fail, but dar will then
76duplicate the inode and file content, issuing a warning.
77
78EXTENDED ATTRIBUTES: support for extended attributes have to be
79activated at compilation time (see INSTALL). Dar is able to save and
80restore EA, all or just those of a given namespace (system or user).
81If no EA have been saved and restoration occurs over a file that has
82EA, they will be preserved. But if they have been saved empty for a
83given file, any existing EA for that file will be removed at
84restoration time, unless -u and/or -U is given on command-line.
85
86ARCHIVE TESTING thanks to CRC (cyclic redundancy checks), dar is able
87to detect data corruption in the archive. Only the file where data
88corruption occurred will not be possible to restore, but dar will
89restore the other even when compression is used.
90
91USING PIPES dar is now able to produce an archive to its standard
92output or named pipe. it is also able to read an archive through a
93pair of pipes, to take a remote archive as reference, or even to
94restore data from a remote archive. This way it is now possible to
95store an archive remotely and in total security (if using encrypted
96means)
97
98ISOLATION the catalogue (i.e.: the contents of an archive), can be
99extracted (this operation is called isolation) to a small file, that
100can in turn be used as reference for differential archive. There is no
101more need to provide an archive to be able to create a differential
102backup over it, just its catalogue is necessary.
103
104RE-SHAPE SLICES OF AN EXISTING ARCHIVE the external program named
105"dar_xform" is able to change the size of slices of a given archive.
106The resulting archive is totally identical to archives directly
107created by dar. Source archive can be taken from a set of slice, from
108standard input or even a named pipe.
109
110%prep
111%setup -q
112
113%build
114
115%{__make}
116
117%install
118rm -rf $RPM_BUILD_ROOT
119install -d $RPM_BUILD_ROOT{/bin,%{_mandir}/man1}
120install dar $RPM_BUILD_ROOT/bin
121install dar_xform $RPM_BUILD_ROOT/bin
122install dar_slave $RPM_BUILD_ROOT/bin
123install *.1 $RPM_BUILD_ROOT%{_mandir}/man1
124
125%clean
126rm -rf $RPM_BUILD_ROOT
127
128%files
129%defattr(644,root,root,755)
130%doc BUGS CHANGES NOTES README TODO TUTORIAL
131%attr(755,root,root) /bin/*
132%attr(644,root,root) %{_mandir}/*
This page took 0.110845 seconds and 4 git commands to generate.