]> git.pld-linux.org Git - packages/cryptsetup.git/blame - cryptsetup.spec
- add -initrd subpackage; rel 4
[packages/cryptsetup.git] / cryptsetup.spec
CommitLineData
5eb10616
JB
1#
2# Conditonal build:
d07d45f7 3%bcond_without initrd # don't build initrd version
5eb10616 4#
d7593791 5%define realname cryptsetup
2488c838 6Summary: LUKS for dm-crypt implemented in cryptsetup
29f5822a 7Summary(pl.UTF-8): LUKS dla dm-crypta zaimplementowany w cryptsetup
6351d6a5 8Name: cryptsetup-luks
f5ec273c 9Version: 1.0.6
d07d45f7 10Release: 4
d7593791 11License: GPL v2
6351d6a5 12Group: Base
d7593791 13Source0: http://luks.endorphin.org/source/%{realname}-%{version}.tar.bz2
f5ec273c 14# Source0-md5: 00d452eb7a76e39f5749545d48934a10
5eb10616 15Patch1: %{name}-nostatic.patch
5616104c 16URL: http://luks.endorphin.org/
5fe93676
JB
17BuildRequires: autoconf
18BuildRequires: automake
0b90291e 19BuildRequires: device-mapper-devel
5fe93676 20BuildRequires: gettext-devel
0b90291e
JB
21BuildRequires: libgcrypt-devel >= 1.1.42
22BuildRequires: libselinux-devel
23BuildRequires: libsepol-devel
d172f920 24BuildRequires: libtool
0b90291e
JB
25BuildRequires: libuuid-devel
26BuildRequires: popt-devel
d07d45f7 27%if %{with initrd}
5eb10616 28BuildRequires: device-mapper-static >= 1.02.07
a6fd3218 29BuildRequires: libgcrypt-static >= 1.1.42
30BuildRequires: libgpg-error-static
31BuildRequires: libselinux-static
8d9e50de 32BuildRequires: libsepol-static
a6fd3218 33BuildRequires: libuuid-static
34BuildRequires: popt-static
5eb10616 35%endif
c0cc5702 36Provides: cryptsetup = %{version}
12cca230 37Obsoletes: cryptsetup
6351d6a5 38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%define _sbindir /sbin
8bf4e8eb 41%define _noautoreqdep libcryptsetup.so.0
6351d6a5 42
43%description
6e98e6fb 44LUKS is the upcoming standard for Linux hard disk encryption. By
45providing a standard on-disk-format, it does not only facilitate
46compatibility among distributions, but also provide secure management
47of multiple user passwords. In contrast to existing solution, LUKS
48stores all setup necessary setup information in the partition header,
49enabling the user to transport or migrate his data seamlessly.
6351d6a5 50
6e98e6fb 51This package contains implementation of LUKS for dm-crypt implemented
52in cryptsetup.
6351d6a5 53
77f30028
JR
54%description -l pl.UTF-8
55LUKS to nadchodzący standard linuksowego szyfrowania twardego dysku.
56Dostarczając standardowy format danych na dysku nie tylko ułatwia
57utrzymanie kompatybilności między dystrybucjami, ale także dostarcza
58bezpieczne zarządzanie wieloma hasłami użytkowników. W przeciwieństwie
59do istniejącego rozwiązania LUKS przechowuje wszystkie potrzebne
60informacje o konfiguracji w nagłówku partycji, pozwalając
61użytkownikowi przenosić lub migrować dane w sposób przezroczysty.
12cca230 62
77f30028 63Ten pakiet zawiera implementację LUKS dla dm-crytpa zaimplementowaną w
12cca230
JB
64cryptsetup.
65
6351d6a5 66%package devel
67Summary: Header files for cryptsetup library
29f5822a 68Summary(pl.UTF-8): Pliki nagłówkowe biblioteki cryptsetup
6351d6a5 69Group: Development/Libraries
70Requires: %{name} = %{version}-%{release}
71Requires: device-mapper-devel
72Requires: libgcrypt-devel >= 1.1.42
12cca230 73Obsoletes: cryptsetup-devel
6351d6a5 74
75%description devel
76Header files for cryptsetup library.
77
77f30028
JR
78%description devel -l pl.UTF-8
79Pliki nagłówkowe biblioteki cryptsetup.
6351d6a5 80
81%package static
82Summary: Static cryptsetup library
29f5822a 83Summary(pl.UTF-8): Statyczna biblioteka cryptsetup
6351d6a5 84Group: Development/Libraries
85Requires: %{name}-devel = %{version}-%{release}
fca9458b 86Obsoletes: cryptsetup-static
6351d6a5 87
88%description static
89Static version of cryptsetup library.
90
77f30028 91%description static -l pl.UTF-8
6351d6a5 92Statyczna wersja biblioteki cryptsetup.
93
d07d45f7
ER
94%package initrd
95Summary: LUKS for dm-crypt implemented in cryptsetup - initrd version
96Group: Base
97
98%description initrd
99This package contains implementation of LUKS for dm-crypt implemented
100in cryptsetup - staticaly linked for initrd.
101
6351d6a5 102%prep
d7593791 103%setup -q -n %{realname}-%{version}
5eb10616 104%patch1 -p1
6351d6a5 105
106%build
8d9e50de 107%{__gettextize}
d7593791 108%{__libtoolize}
8d9e50de 109%{__aclocal} -I m4
110%{__autoconf}
d7593791 111%{__autoheader}
8d9e50de 112%{__automake}
d07d45f7
ER
113
114%if %{with initrd}
a6fd3218 115%configure \
5eb10616 116 --enable-static \
d07d45f7
ER
117 --enable-static-cryptsetup
118%{__make}
119mv src/cryptsetup cryptsetup-initrd
120%{__make} clean
121%endif
122
123%configure \
124 --enable-static
6351d6a5 125%{__make}
126
127%install
128rm -rf $RPM_BUILD_ROOT
129
130%{__make} install \
131 DESTDIR=$RPM_BUILD_ROOT
132
133install -d $RPM_BUILD_ROOT/%{_lib}
d7593791
JB
134mv -f $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so.* $RPM_BUILD_ROOT/%{_lib}
135ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libcryptsetup.so.*.*.*) \
6351d6a5 136 $RPM_BUILD_ROOT%{_libdir}/libcryptsetup.so
137
d07d45f7
ER
138%if %{with initrd}
139install cryptsetup-initrd $RPM_BUILD_ROOT%{_sbindir}
140%endif
141
d7593791 142%find_lang %{realname}
6351d6a5 143
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%post -p /sbin/ldconfig
148%postun -p /sbin/ldconfig
149
d7593791 150%files -f %{realname}.lang
6351d6a5 151%defattr(644,root,root,755)
d7593791 152%doc AUTHORS ChangeLog TODO
6351d6a5 153%attr(755,root,root) %{_sbindir}/cryptsetup
154%attr(755,root,root) /%{_lib}/libcryptsetup.so.*.*.*
d7593791
JB
155%attr(755,root,root) %ghost /%{_lib}/libcryptsetup.so.0
156%{_mandir}/man8/cryptsetup.8*
6351d6a5 157
158%files devel
159%defattr(644,root,root,755)
160%attr(755,root,root) %{_libdir}/libcryptsetup.so
161%{_libdir}/libcryptsetup.la
d7593791 162%{_includedir}/libcryptsetup.h
6351d6a5 163
a6fd3218 164%files static
165%defattr(644,root,root,755)
166%{_libdir}/libcryptsetup.a
d07d45f7
ER
167
168%if %{with initrd}
169%files initrd
170%defattr(644,root,root,755)
171%attr(755,root,root) %{_sbindir}/cryptsetup-initrd
172%endif
This page took 0.075251 seconds and 4 git commands to generate.