]> git.pld-linux.org Git - packages/codeblocks.git/blame - codeblocks.spec
- Code::Blocks - free C/C++ IDE, nfy.
[packages/codeblocks.git] / codeblocks.spec
CommitLineData
f2e658c8
PS
1Summary: An open source, cross platform, free C++ IDE
2Name: codeblocks
3Version: 1.0
4%define _rc rc2
5Release: 0.%{_rc}.0.1
6License: GPL
7Group: Development/Languages
8Source0: http://dl.sourceforge.net/codeblocks/%{name}-%{version}%{_rc}.tgz
9# Source0-md5: 0
10URL: http://www.codeblocks.org/
11BuildRequires: autoconf
12BuildRequires: automake
13BuildRequires: dos2unix
14BuildRequires: libtool
15BuildRequires: wxGTK2-devel
16BuildRequires: wxWindows-devel
17BuildRequires: zip
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21Code::Blocks is a free C++ IDE built specifically to meet the most
22demanding needs of its users. It was designed, right from the start,
23to be extensible and configurable. Built around a plugin framework,
24Code::Blocks can be extended with plugin DLLs. It includes a plugin
25wizard so you can compile your own plugins!
26
27Features:
28
29Highlights:
30
31 - Open Source! GPL2, no hidden costs.
32 - Cross-platform. Runs on Linux or Windows (uses wxWidgets).
33 - Made in GNU C++. No interpreted languages or proprietary libs
34 needed.
35 - Comes in two presentations: Standalone, and MinGW bundle
36 - Devpack support (optional)
37 - Extensible thru plugins (SDK available in the downloads section)
38
39Compiler-related features:
40
41 - Multiple compiler support:
42 - GCC (MingW / Linux GCC)
43 - MSVC++
44 - Digital Mars
45 - Borland C++ 5.5
46 - Open Watcom
47 - Compiles directly or with makefiles
48 - Predefined project templates
49 - Custom template support
50 - Uses XML format for project files.
51 - Multi-target projects
52 - Workspaces support
53 - Imports MSVC projects and workspaces (NOTE: assembly code and
54 inter-project dependencies not supported yet)
55 - Imports Dev-C++ projects
56 - Integrates with GDB for debugging
57
58Interface Features:
59
60 - Syntax highlighting, customizable and extensible
61 - Code folding for C++ and XML files.
62 - Tabbed interface
63 - Code completion plugin
64 - Class Browser
65 - Smart indent
66 - One-key swap between .h and .c/.cpp files
67 - Open files list for quick switching between files (optional)
68 - External customizable "Tools"
69 - To-do list management with different users
70
71%prep
72%setup -q -n %{name}-%{version}%{_rc}
73find . -type f -and -not -name "*.cpp" -and -not -name "*.h" -and -not -name "*.png" -and -not -name "*.bmp" -and -not -name "*.c" -and -not -name "*.cxx" -and -not -name "*.ico" | sed "s/.*/\"\\0\"/" | xargs dos2unix
74chmod a+x acinclude.m4 src/update
75
76%build
77%{__libtoolize}
78%{__aclocal}
79%{__autoconf}
80%{__autoheader}
81%{__automake}
82%configure \
83 --with-wx-config=wx-gtk2-ansi-config
84%{__make}
85
86%install
87rm -rf $RPM_BUILD_ROOT
88
89%{__make} install \
90 DESTDIR=$RPM_BUILD_ROOT
91
92%clean
93rm -rf $RPM_BUILD_ROOT
94
95%post -p /sbin/ldconfig
96%postun -p /sbin/ldconfig
97
98%files
99%defattr(644,root,root,755)
100#doc README COPYING AUTHORS BUGS COMPILERS TODO NEWS ChangeLog
101%attr(755,root,root) %{_bindir}/codeblocks
102%attr(755,root,root) %{_bindir}/console_runner
103%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
104#{_datadir}/application-registry/codeblocks.applications
105#{_datadir}/applications/codeblocks.desktop
106#{_datadir}/icons/gnome/48x48/mimetypes/gnome-mime-application-x-codeblocks.png
107#{_datadir}/mime-info/*
108#{_datadir}/mime/packages/codeblocks.xml
109#{_datadir}/pixmaps/codeblocks.png
110#define pkgdata %{_datadir}/%{name}
111#{pkgdata}/*
This page took 0.104942 seconds and 4 git commands to generate.