]> git.pld-linux.org Git - packages/busybox.git/blame - busybox.spec
- rel4; support math in ash for initrd
[packages/busybox.git] / busybox.spec
CommitLineData
2678f462 1#
598da0d3
JB
2# TODO: sparc64 modules support in sparc(32) version
3#
2678f462 4# Conditional build:
b5011fd7 5# alternative busybox config file (replaces default one) you should
4a69c6c5 6# define cfgfile macro, i.e.
d635bde0 7#
8# rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
2678f462
JB
9%bcond_with altconfig # use alternative config (defined by cfgfile)
10%bcond_with linkfl # creates links to busybox binary and puts them into file list
d635bde0 11# Options below are useful, when you want fileutils and grep providing.
12# For example, ash package requires fileutils and grep.
2678f462
JB
13%bcond_with fileutl_prov # adds fileutils providing
14%bcond_with grep_prov # adds grep providing
d635bde0 15# Option below is useful, when busybox is built with shell support.
2678f462 16%bcond_with sh_prov # adds /bin/sh providing
d635bde0 17# WARNING! Shell, filetuils and grep providing may depend on config file!
18# Fileutils, grep and shell provided with busybox have not such
19# functionality as their GNU countenders.
2678f462
JB
20#
21%bcond_without static # don't build static version
22%bcond_without initrd # don't build initrd version
23%bcond_with dietlibc # build dietlibc-based initrd version
24%bcond_with glibc # build glibc-based initrd version
25#
6714aad6 26%ifnarch %{ix86}
1735ff25
MM
27%define with_glibc 1
28%endif
ee61dafa 29Summary: Set of common unix utils for embeded systems
b7f899e9 30