]> git.pld-linux.org Git - packages/busybox.git/blame - busybox.spec
- up to 1.2.1
[packages/busybox.git] / busybox.spec
CommitLineData
e7982b05 1# TODO:
9296731a 2# - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
e7982b05 3# - make internal commands work even if busybox is not in /bin/busybox
598da0d3 4#
2678f462 5# Conditional build:
b5011fd7 6# alternative busybox config file (replaces default one) you should
4a69c6c5 7# define cfgfile macro, i.e.
d635bde0 8#
6f6b5afa 9# rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
2678f462
JB
10%bcond_with altconfig # use alternative config (defined by cfgfile)
11%bcond_with linkfl # creates links to busybox binary and puts them into file list
d635bde0 12# Options below are useful, when you want fileutils and grep providing.
13# For example, ash package requires fileutils and grep.
2678f462
JB
14%bcond_with fileutl_prov # adds fileutils providing
15%bcond_with grep_prov # adds grep providing
d635bde0 16# Option below is useful, when busybox is built with shell support.
2678f462 17%bcond_with sh_prov # adds /bin/sh providing
6b50dd3e 18# WARNING! Shell, fileutils and grep providing may depend on config file!
d635bde0 19# Fileutils, grep and shell provided with busybox have not such
20# functionality as their GNU countenders.
2678f462
JB
21#
22%bcond_without static # don't build static version
23%bcond_without initrd # don't build initrd version
95f61a42 24#%%bcond_with dietlibc # build dietlibc-based initrd version
2678f462
JB
25%bcond_with glibc # build glibc-based initrd version
26#
95f61a42 27%ifnarch %{ix86} %{x8664} ppc
1735ff25
MM
28%define with_glibc 1
29%endif
9a45af3a 30%ifarch ppc
31%undefine with_dietlibc
32%endif
ee61dafa 33Summary: Set of common unix utils for embeded systems
b7f899e9 34