]> git.pld-linux.org Git - packages/busybox.git/blame - busybox.spec
Up to 1.34.1 but fails to link
[packages/busybox.git] / busybox.spec
CommitLineData
e7982b05 1# TODO:
a54ace54
CM
2# - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3# if it still serves a purpose
4# - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5# - make internal commands work even if busybox is not in /bin/busybox (initrd)
6# or when /proc is not mounted (static / normal)
598da0d3 7#
2678f462 8# Conditional build:
b5011fd7 9# alternative busybox config file (replaces default one) you should
4a69c6c5 10# define cfgfile macro, i.e.
d635bde0 11#
6f6b5afa 12# rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
a54ace54 13#
2678f462
JB
14%bcond_with altconfig # use alternative config (defined by cfgfile)
15%bcond_with linkfl # creates links to busybox binary and puts them into file list
63de0802 16%bcond_without dynamic # don't build dynamic (base) version
3637c580
JR
17%bcond_without static # don't build static version
18%bcond_without initrd # don't build initrd version
19%bcond_with dietlibc # build dietlibc-based initrd and static versions
20%bcond_with glibc # build glibc-based initrd and static versions
494a100b 21%bcond_without verbose # verbose build
d635bde0 22# Options below are useful, when you want fileutils and grep providing.
23# For example, ash package requires fileutils and grep.
2678f462
JB
24%bcond_with fileutl_prov # adds fileutils providing
25%bcond_with grep_prov # adds grep providing
d635bde0 26# Option below is useful, when busybox is built with shell support.
2678f462 27%bcond_with sh_prov # adds /bin/sh providing
6b50dd3e 28# WARNING! Shell, fileutils and grep providing may depend on config file!
d635bde0 29# Fileutils, grep and shell provided with busybox have not such
30# functionality as their GNU countenders.
2678f462 31#
c15e3058 32%ifnarch %{ix86} %{x8664} ppc
4ec69b2b
JR
33%define with_glibc 1
34%endif
35%ifarch x32
36# until uClibc builds on x32
37%undefine with_static
1735ff25 38%endif
dce89576 39Summary: Set of common Unix utilities for embeded systems
718bff43
ER
40Summary(pl.UTF-8): Zestaw narzędzi uniksowych dla systemów wbudowanych
41Summary(pt_BR.UTF-8): BusyBox é um conjunto de utilitários UNIX em um único binário
ee61dafa 42Name: busybox
586f52e3 43# stable line only
a7f0a442
AM
44Version: 1.34.1
45Release: 0.1
bbbc183d 46License: GPL v2
d79d7625 47Group: Applications
693dc2a0 48Source0: http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
a7f0a442 49# Source0-md5: 5ad7368a73d12b8c4f8881bf7afb3d82
4f8fe04f
AM
50Source1: %{name}.config
51Source2: %{name}-initrd.config
8f98fac8 52%{?with_altconfig:Source3: %{cfgfile}}
aad3a7f3 53Patch0: x32.patch
b2b9509f 54Patch1: %{name}-logconsole.patch
55Patch2: %{name}-printf-gettext.patch
56Patch3: %{name}-loadfont.patch
29a4a582
JR
57Patch4: %{name}-kernel_headers.patch
58Patch5: %{name}-insmod-morearchs.patch
59Patch6: %{name}-dhcp.patch
60Patch7: %{name}-fix_64_archs.patch
7a6bf0ae 61Patch8: busybox-1.31.1-stime-fix.patch
29a4a582 62Patch9: %{name}-ash-export-PATH.patch
87902b66 63URL: http://www.busybox.net/
255676bf 64BuildRequires: gcc >= 3.2
839c36a5 65BuildRequires: perl-tools-pod
d41f35db 66BuildRequires: rpmbuild(macros) >= 1.652
6648e383
JP
67%if %{with glibc}
68BuildRequires: libtirpc-devel
69BuildRequires: pkgconfig
70%endif
ef0df9c1 71%if %{with initrd} || %{with static}
6f6b5afa 72 %if %{with dietlibc}
1735ff25 73BuildRequires: dietlibc-static
6f6b5afa 74 %else
75 %if %{with glibc}
1735ff25 76BuildRequires: glibc-static
6648e383 77BuildRequires: libtirpc-static
6f6b5afa 78 %else
cbbddfaa 79%if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 80BuildRequires: cross%{_target_base_arch}-uClibc-static
9a45af3a 81%else
9922ba41 82 %ifarch ppc %{x8664}
c574afd9 83BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 84 %else
c574afd9 85BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 86 %endif
9a45af3a 87%endif
6f6b5afa 88 %endif
89 %endif
1735ff25 90%endif
a54ace54 91%{?with_sh_prov:Provides: /bin/sh}
2678f462
JB
92%{?with_fileutl_prov:Provides: fileutils}
93%{?with_grep_prov:Provides: grep}
0f80cc3e 94Provides: busybox-implementation = %{version}-%{release}
ee61dafa
MM
95BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
e7982b05 97%define _bindir /bin
fc11b50f 98
cbbddfaa 99%if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 100 %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
101%else
102 %define CrossOpts %{nil}
103%endif
104
558ca139
JR
105%define filterout_ld -Wl,-z,(combreloc|relro)
106
6648e383
JP
107%if %{with glibc}
108%define tirpccflags %(pkg-config --cflags libtirpc)
109%if %{with initrd} || %{with static}
110%define tirpcslibs %(pkg-config --libs --static libtirpc|sed s/-l//g)
111%endif
112%if %{with dynamic}
113%define tirpcdlibs %(pkg-config --libs libtirpc|sed s/-l//g)
114%endif
115%endif
116
ee61dafa 117%description
65512310 118BusyBox combines tiny versions of many common UNIX utilities into a
119single small executable. It provides minimalist replacements for most
120of the utilities you usually find in fileutils, shellutils, findutils,
121textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
122POSIX environment for any small or embedded system. The utilities in
123BusyBox generally have fewer options than their full-featured GNU
124cousins; however, the options that are included provide the expected
125functionality and behave very much like their GNU counterparts.
126
127BusyBox has been written with size-optimization and limited resources
128in mind. It is also extremely modular so you can easily include or
129exclude commands (or features) at compile time. This makes it easy to
130customize your embedded systems. To create a working system, just add
131a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
132ae).
ee61dafa 133
c499e458
JR
134%description -l pl.UTF-8
135BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
136wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
b7f899e9 137zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
c499e458
JR
138tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
139lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
140odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
b7f899e9
JB
141systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
142(np. elvis-tiny albo ae).
143
c499e458
JR
144%description -l pt_BR.UTF-8
145BusyBox combina versões reduzidas de muitos utilitários UNIX num único
146executável, fornecendo substitutos minimalistas para muitos dos
147executáveis encontrados em pacotes como fileutils, shellutils,
148findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
149em geral têm menos opções que os utilitários GNU, mas as opções
68092394 150implementadas comportam-se de maneira similar aos equivalentes GNU.
151
34ec6041
JB
152%package static
153Summary: Static busybox
718bff43 154Summary(pl.UTF-8): Statycznie skonsolidowany busybox
34ec6041 155Group: Applications
34ec6041
JB
156
157%description static
158Static busybox.
159
c499e458 160%description static -l pl.UTF-8
dfafd31f 161Statycznie skonsolidowany busybox.
34ec6041 162
52db7bd4
MM
163%package initrd
164Summary: Static busybox for initrd
718bff43 165Summary(pl.UTF-8): Statycznie skonsolidowany busybox dla initrd
11aa4d91 166Group: Base
1857f402 167Conflicts: geninitrd < 10000.20
0f80cc3e 168Provides: busybox-implementation = %{version}-%{release}
52db7bd4
MM
169
170%description initrd
171Static busybox for initrd.
172
c499e458 173%description initrd -l pl.UTF-8
dfafd31f 174Statycznie skonsolidowany busybox dla initrd.
52db7bd4 175
ee61dafa 176%prep
693dc2a0 177%setup -q
aad3a7f3 178%patch0 -p1
0b555ee8
JB
179%patch1 -p1
180%patch2 -p1
a54ace54 181#%patch3 -p1
0cf45dc5 182%patch4 -p1
0b555ee8 183%patch5 -p1
5a7abf9a 184%patch6 -p1
0b555ee8 185%patch7 -p1
7a6bf0ae 186%patch8 -p1
586f52e3 187%patch9 -p1
ea0cda84 188
ee61dafa 189%build
839c36a5 190install -d built
52db7bd4 191%if %{with initrd}
4f8fe04f 192install %{SOURCE2} .config
6648e383 193echo 'CONFIG_EXTRA_LDLIBS="%{?with_glibc:%{tirpcslibs}}"' >> .config
4f8fe04f 194%{__make} oldconfig
52db7bd4 195%{__make} \
91a4c8e3 196 %{?with_verbose:V=1} \
6648e383 197 EXTRA_CFLAGS="%{rpmcflags} %{?with_glibc:%{tirpccflags}} -Os -D_BSD_SOURCE" \
fb8bb2b8 198 EXTRA_LDFLAGS="%{rpmldflags} -static -Wl,-z,noexecstack" \
27ca3ce9 199%if %{with dietlibc}
52db7bd4 200 LIBRARIES="-lrpc" \
661e2e64 201 CC="diet %{__cc}"
1735ff25
MM
202%else
203%if %{with glibc}
9922ba41 204 %{CrossOpts} \
1735ff25 205 CC="%{__cc}"
27ca3ce9 206%else
cbbddfaa 207 %if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 208 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 209 %endif
27ca3ce9
AM
210 CC="%{_target_cpu}-uclibc-gcc"
211%endif
1735ff25
MM
212%endif
213
839c36a5 214mv -f busybox built/busybox.initrd
52db7bd4 215%{__make} clean
52db7bd4
MM
216%endif
217
6648e383 218%if %{with static}
1735ff25
MM
219%if %{with altconfig}
220install %{SOURCE3} .config
13fc95fb
ER
221%else
222install %{SOURCE1} .config
6648e383 223echo 'CONFIG_EXTRA_LDLIBS="%{?with_glibc:%{tirpcslibs}}"' >> .config
1735ff25 224%endif
4f8fe04f 225%{__make} oldconfig
6f6b5afa 226%{__make} \
91a4c8e3 227 %{?with_verbose:V=1} \
6648e383 228 EXTRA_CFLAGS="%{rpmcflags} %{?with_glibc:%{tirpccflags}} -Os -D_BSD_SOURCE" \
fb8bb2b8 229 EXTRA_LDFLAGS="%{rpmldflags} -static -Wl,-z,noexecstack" \
ef0df9c1
JR
230%if %{with dietlibc}
231 LIBRARIES="-lrpc" \
661e2e64 232 CC="diet %{__cc}"
ef0df9c1
JR
233%else
234%if %{with glibc}
235 %{CrossOpts} \
52db7bd4 236 CC="%{__cc}"
ef0df9c1 237%else
cbbddfaa 238 %if "%{_target_base_arch}" != "%{_host_base_arch}"
ef0df9c1 239 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 240 %endif
ef0df9c1
JR
241 CC="%{_target_cpu}-uclibc-gcc"
242%endif
243%endif
244
839c36a5 245mv -f busybox built/busybox.static
2481202a 246%{__make} clean
34ec6041 247%endif
2481202a 248
63de0802 249%if %{with dynamic}
6648e383
JP
250%if %{with altconfig}
251install %{SOURCE3} .config
252%else
253install %{SOURCE1} .config
254echo 'CONFIG_EXTRA_LDLIBS="%{?with_glibc:%{tirpcdlibs}}"' >> .config
255%endif
b5011fd7 256%{__make} oldconfig
b7f899e9 257%{__make} \
91a4c8e3 258 %{?with_verbose:V=1} \
9922ba41 259 %{CrossOpts} \
6648e383 260 EXTRA_CFLAGS="%{rpmcflags} %{?with_glibc:%{tirpccflags}}" \
fb8bb2b8 261 EXTRA_LDFLAGS="%{rpmldflags} -Wl,-z,noexecstack" \
f5ad7fd6 262 CC="%{__cc}"
bf1f4257 263%{__make} busybox.links docs/busybox.1
63de0802 264%endif
4e2ab1f5 265
ee61dafa
MM
266%install
267rm -rf $RPM_BUILD_ROOT
b7f899e9 268
63de0802
JB
269%if %{with static}
270install -d $RPM_BUILD_ROOT%{_bindir}
271install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
272%endif
273
a71afd72
JR
274%if %{with initrd}
275install -d $RPM_BUILD_ROOT%{_libdir}/initrd
1857f402 276install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
a71afd72 277%endif
34ec6041 278
63de0802
JB
279%if %{with dynamic}
280install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
b7f899e9 281install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
bf1f4257 282install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
ee61dafa 283
d635bde0 284# install links to busybox binary, when linkfl is defined
4a69c6c5 285%if %{with linkfl}
2678f462 286%{__make} install \
5a7abf9a 287 PREFIX=$RPM_BUILD_ROOT
4a69c6c5
MM
288%else
289install busybox $RPM_BUILD_ROOT%{_bindir}
290%endif
63de0802 291%endif
d635bde0 292
ee61dafa
MM
293%clean
294rm -rf $RPM_BUILD_ROOT
295
63de0802 296%if %{with dynamic}
ee61dafa
MM
297%files
298%defattr(644,root,root,755)
a230e0df 299%doc AUTHORS README .config
d635bde0 300
4a69c6c5 301%if %{with linkfl}
77109ddb 302%attr(755,root,root) /bin/*
d635bde0 303%attr(755,root,root) /sbin/*
304%attr(755,root,root) %{_bindir}/*
305%attr(755,root,root) %{_sbindir}/*
4a69c6c5
MM
306%else
307%attr(755,root,root) %{_bindir}/busybox
d635bde0 308%endif
309
65512310 310%{_libdir}/busybox
77109ddb 311%{_mandir}/man1/busybox.1*
63de0802 312%endif
bb4ca08e 313
4a69c6c5 314%if %{with static}
34ec6041
JB
315%files static
316%defattr(644,root,root,755)
317%attr(755,root,root) %{_bindir}/busybox.static
318%endif
52db7bd4
MM
319
320%if %{with initrd}
321%files initrd
322%defattr(644,root,root,755)
1857f402 323%attr(755,root,root) %{_libdir}/initrd/busybox
52db7bd4 324%endif
This page took 0.131996 seconds and 4 git commands to generate.