]> git.pld-linux.org Git - packages/busybox.git/blame - busybox.spec
- stupid me according to RFC 959 STOR uses full path, CWD is not needed
[packages/busybox.git] / busybox.spec
CommitLineData
2678f462 1#
e7982b05
AM
2# TODO:
3# - sparc64 modules support in sparc(32) version
4# - make internal commands work even if busybox is not in /bin/busybox
5#
598da0d3 6#
2678f462 7# Conditional build:
b5011fd7 8# alternative busybox config file (replaces default one) you should
4a69c6c5 9# define cfgfile macro, i.e.
d635bde0 10#
6f6b5afa 11# rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
2678f462
JB
12%bcond_with altconfig # use alternative config (defined by cfgfile)
13%bcond_with linkfl # creates links to busybox binary and puts them into file list
d635bde0 14# Options below are useful, when you want fileutils and grep providing.
15# For example, ash package requires fileutils and grep.
2678f462
JB
16%bcond_with fileutl_prov # adds fileutils providing
17%bcond_with grep_prov # adds grep providing
d635bde0 18# Option below is useful, when busybox is built with shell support.
2678f462 19%bcond_with sh_prov # adds /bin/sh providing
d635bde0 20# WARNING! Shell, filetuils and grep providing may depend on config file!
21# Fileutils, grep and shell provided with busybox have not such
22# functionality as their GNU countenders.
2678f462
JB
23#
24%bcond_without static # don't build static version
25%bcond_without initrd # don't build initrd version
26%bcond_with dietlibc # build dietlibc-based initrd version
27%bcond_with glibc # build glibc-based initrd version
28#
6714aad6 29%ifnarch %{ix86}
1735ff25
MM
30%define with_glibc 1
31%endif
ee61dafa 32Summary: Set of common unix utils for embeded systems
b7f899e9 33