]> git.pld-linux.org Git - packages/busybox.git/blame - busybox.spec
- updated to 1.23.2
[packages/busybox.git] / busybox.spec
CommitLineData
e7982b05 1# TODO:
a54ace54
CM
2# - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3# if it still serves a purpose
4# - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5# - make internal commands work even if busybox is not in /bin/busybox (initrd)
6# or when /proc is not mounted (static / normal)
598da0d3 7#
2678f462 8# Conditional build:
b5011fd7 9# alternative busybox config file (replaces default one) you should
4a69c6c5 10# define cfgfile macro, i.e.
d635bde0 11#
6f6b5afa 12# rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
a54ace54 13#
2678f462
JB
14%bcond_with altconfig # use alternative config (defined by cfgfile)
15%bcond_with linkfl # creates links to busybox binary and puts them into file list
63de0802 16%bcond_without dynamic # don't build dynamic (base) version
3637c580
JR
17%bcond_without static # don't build static version
18%bcond_without initrd # don't build initrd version
19%bcond_with dietlibc # build dietlibc-based initrd and static versions
20%bcond_with glibc # build glibc-based initrd and static versions
494a100b 21%bcond_without verbose # verbose build
d635bde0 22# Options below are useful, when you want fileutils and grep providing.
23# For example, ash package requires fileutils and grep.
2678f462
JB
24%bcond_with fileutl_prov # adds fileutils providing
25%bcond_with grep_prov # adds grep providing
d635bde0 26# Option below is useful, when busybox is built with shell support.
2678f462 27%bcond_with sh_prov # adds /bin/sh providing
6b50dd3e 28# WARNING! Shell, fileutils and grep providing may depend on config file!
d635bde0 29# Fileutils, grep and shell provided with busybox have not such
30# functionality as their GNU countenders.
2678f462 31#
c15e3058 32%ifnarch %{ix86} %{x8664} ppc
4ec69b2b
JR
33%define with_glibc 1
34%endif
35%ifarch x32
36# until uClibc builds on x32
37%undefine with_static
1735ff25 38%endif
dce89576 39Summary: Set of common Unix utilities for embeded systems
718bff43
ER
40Summary(pl.UTF-8): Zestaw narzędzi uniksowych dla systemów wbudowanych
41Summary(pt_BR.UTF-8): BusyBox é um conjunto de utilitários UNIX em um único binário
ee61dafa 42Name: busybox
586f52e3 43# stable line only
50bbf402
JB
44Version: 1.23.2
45Release: 1
bbbc183d 46License: GPL v2
d79d7625 47Group: Applications
693dc2a0 48Source0: http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
50bbf402 49# Source0-md5: 7925683d7dd105aabe9b6b618d48cc73
4f8fe04f
AM
50Source1: %{name}.config
51Source2: %{name}-initrd.config
8f98fac8 52%{?with_altconfig:Source3: %{cfgfile}}
aad3a7f3 53Patch0: x32.patch
b2b9509f 54Patch1: %{name}-logconsole.patch
55Patch2: %{name}-printf-gettext.patch
56Patch3: %{name}-loadfont.patch
29a4a582
JR
57Patch4: %{name}-kernel_headers.patch
58Patch5: %{name}-insmod-morearchs.patch
59Patch6: %{name}-dhcp.patch
60Patch7: %{name}-fix_64_archs.patch
29a4a582 61Patch9: %{name}-ash-export-PATH.patch
87902b66 62URL: http://www.busybox.net/
255676bf 63BuildRequires: gcc >= 3.2
839c36a5 64BuildRequires: perl-tools-pod
d41f35db 65BuildRequires: rpmbuild(macros) >= 1.652
ef0df9c1 66%if %{with initrd} || %{with static}
6f6b5afa 67 %if %{with dietlibc}
1735ff25 68BuildRequires: dietlibc-static
6f6b5afa 69 %else
70 %if %{with glibc}
1735ff25 71BuildRequires: glibc-static
6f6b5afa 72 %else
cbbddfaa 73%if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 74BuildRequires: cross%{_target_base_arch}-uClibc-static
9a45af3a 75%else
9922ba41 76 %ifarch ppc %{x8664}
c574afd9 77BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 78 %else
c574afd9 79BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 80 %endif
9a45af3a 81%endif
6f6b5afa 82 %endif
83 %endif
1735ff25 84%endif
a54ace54 85%{?with_sh_prov:Provides: /bin/sh}
2678f462
JB
86%{?with_fileutl_prov:Provides: fileutils}
87%{?with_grep_prov:Provides: grep}
ee61dafa
MM
88BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
e7982b05 90%define _bindir /bin
fc11b50f 91
cbbddfaa 92%if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 93 %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
94%else
95 %define CrossOpts %{nil}
96%endif
97
558ca139
JR
98%define filterout_ld -Wl,-z,(combreloc|relro)
99
ee61dafa 100%description
65512310 101BusyBox combines tiny versions of many common UNIX utilities into a
102single small executable. It provides minimalist replacements for most
103of the utilities you usually find in fileutils, shellutils, findutils,
104textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
105POSIX environment for any small or embedded system. The utilities in
106BusyBox generally have fewer options than their full-featured GNU
107cousins; however, the options that are included provide the expected
108functionality and behave very much like their GNU counterparts.
109
110BusyBox has been written with size-optimization and limited resources
111in mind. It is also extremely modular so you can easily include or
112exclude commands (or features) at compile time. This makes it easy to
113customize your embedded systems. To create a working system, just add
114a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
115ae).
ee61dafa 116
c499e458
JR
117%description -l pl.UTF-8
118BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
119wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
b7f899e9 120zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
c499e458
JR
121tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
122lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
123odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
b7f899e9
JB
124systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
125(np. elvis-tiny albo ae).
126
c499e458
JR
127%description -l pt_BR.UTF-8
128BusyBox combina versões reduzidas de muitos utilitários UNIX num único
129executável, fornecendo substitutos minimalistas para muitos dos
130executáveis encontrados em pacotes como fileutils, shellutils,
131findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
132em geral têm menos opções que os utilitários GNU, mas as opções
68092394 133implementadas comportam-se de maneira similar aos equivalentes GNU.
134
34ec6041
JB
135%package static
136Summary: Static busybox
718bff43 137Summary(pl.UTF-8): Statycznie skonsolidowany busybox
34ec6041 138Group: Applications
34ec6041
JB
139
140%description static
141Static busybox.
142
c499e458 143%description static -l pl.UTF-8
dfafd31f 144Statycznie skonsolidowany busybox.
34ec6041 145
52db7bd4
MM
146%package initrd
147Summary: Static busybox for initrd
718bff43 148Summary(pl.UTF-8): Statycznie skonsolidowany busybox dla initrd
11aa4d91 149Group: Base
1857f402 150Conflicts: geninitrd < 10000.20
52db7bd4
MM
151
152%description initrd
153Static busybox for initrd.
154
c499e458 155%description initrd -l pl.UTF-8
dfafd31f 156Statycznie skonsolidowany busybox dla initrd.
52db7bd4 157
ee61dafa 158%prep
693dc2a0 159%setup -q
aad3a7f3 160%patch0 -p1
0b555ee8
JB
161%patch1 -p1
162%patch2 -p1
a54ace54 163#%patch3 -p1
0cf45dc5 164%patch4 -p1
0b555ee8 165%patch5 -p1
5a7abf9a 166%patch6 -p1
0b555ee8 167%patch7 -p1
586f52e3 168%patch9 -p1
ea0cda84 169
ee61dafa 170%build
839c36a5 171install -d built
52db7bd4 172%if %{with initrd}
4f8fe04f
AM
173install %{SOURCE2} .config
174%{__make} oldconfig
52db7bd4 175%{__make} \
91a4c8e3 176 %{?with_verbose:V=1} \
95f61a42 177 CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
63de0802 178 LDFLAGS="%{rpmldflags} -static" \
27ca3ce9 179%if %{with dietlibc}
52db7bd4 180 LIBRARIES="-lrpc" \
661e2e64 181 CC="diet %{__cc}"
1735ff25
MM
182%else
183%if %{with glibc}
9922ba41 184 %{CrossOpts} \
1735ff25 185 CC="%{__cc}"
27ca3ce9 186%else
cbbddfaa 187 %if "%{_target_base_arch}" != "%{_host_base_arch}"
9922ba41 188 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 189 %endif
27ca3ce9
AM
190 CC="%{_target_cpu}-uclibc-gcc"
191%endif
1735ff25
MM
192%endif
193
839c36a5 194mv -f busybox built/busybox.initrd
52db7bd4 195%{__make} clean
52db7bd4
MM
196%endif
197
1735ff25
MM
198%if %{with altconfig}
199install %{SOURCE3} .config
13fc95fb
ER
200%else
201install %{SOURCE1} .config
1735ff25
MM
202%endif
203
4a69c6c5 204%if %{with static}
4f8fe04f 205%{__make} oldconfig
6f6b5afa 206%{__make} \
91a4c8e3 207 %{?with_verbose:V=1} \
ef0df9c1 208 CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
63de0802 209 LDFLAGS="%{rpmldflags} -static" \
ef0df9c1
JR
210%if %{with dietlibc}
211 LIBRARIES="-lrpc" \
661e2e64 212 CC="diet %{__cc}"
ef0df9c1
JR
213%else
214%if %{with glibc}
215 %{CrossOpts} \
52db7bd4 216 CC="%{__cc}"
ef0df9c1 217%else
cbbddfaa 218 %if "%{_target_base_arch}" != "%{_host_base_arch}"
ef0df9c1 219 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 220 %endif
ef0df9c1
JR
221 CC="%{_target_cpu}-uclibc-gcc"
222%endif
223%endif
224
839c36a5 225mv -f busybox built/busybox.static
2481202a 226%{__make} clean
34ec6041 227%endif
2481202a 228
63de0802 229%if %{with dynamic}
b5011fd7 230%{__make} oldconfig
b7f899e9 231%{__make} \
91a4c8e3 232 %{?with_verbose:V=1} \
9922ba41 233 %{CrossOpts} \
b7f899e9 234 CFLAGS_EXTRA="%{rpmcflags}" \
63de0802 235 LDFLAGS="%{rpmldflags}" \
f5ad7fd6 236 CC="%{__cc}"
bf1f4257 237%{__make} busybox.links docs/busybox.1
63de0802 238%endif
4e2ab1f5 239
ee61dafa
MM
240%install
241rm -rf $RPM_BUILD_ROOT
b7f899e9 242
63de0802
JB
243%if %{with static}
244install -d $RPM_BUILD_ROOT%{_bindir}
245install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
246%endif
247
a71afd72
JR
248%if %{with initrd}
249install -d $RPM_BUILD_ROOT%{_libdir}/initrd
1857f402 250install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
a71afd72 251%endif
34ec6041 252
63de0802
JB
253%if %{with dynamic}
254install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
b7f899e9 255install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
bf1f4257 256install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
ee61dafa 257
d635bde0 258# install links to busybox binary, when linkfl is defined
4a69c6c5 259%if %{with linkfl}
2678f462 260%{__make} install \
5a7abf9a 261 PREFIX=$RPM_BUILD_ROOT
4a69c6c5
MM
262%else
263install busybox $RPM_BUILD_ROOT%{_bindir}
264%endif
63de0802 265%endif
d635bde0 266
ee61dafa
MM
267%clean
268rm -rf $RPM_BUILD_ROOT
269
63de0802 270%if %{with dynamic}
ee61dafa
MM
271%files
272%defattr(644,root,root,755)
a230e0df 273%doc AUTHORS README .config
d635bde0 274
4a69c6c5 275%if %{with linkfl}
77109ddb 276%attr(755,root,root) /bin/*
d635bde0 277%attr(755,root,root) /sbin/*
278%attr(755,root,root) %{_bindir}/*
279%attr(755,root,root) %{_sbindir}/*
4a69c6c5
MM
280%else
281%attr(755,root,root) %{_bindir}/busybox
d635bde0 282%endif
283
65512310 284%{_libdir}/busybox
77109ddb 285%{_mandir}/man1/busybox.1*
63de0802 286%endif
bb4ca08e 287
4a69c6c5 288%if %{with static}
34ec6041
JB
289%files static
290%defattr(644,root,root,755)
291%attr(755,root,root) %{_bindir}/busybox.static
292%endif
52db7bd4
MM
293
294%if %{with initrd}
295%files initrd
296%defattr(644,root,root,755)
1857f402 297%attr(755,root,root) %{_libdir}/initrd/busybox
52db7bd4 298%endif
This page took 0.14721 seconds and 4 git commands to generate.