]> git.pld-linux.org Git - packages/busybox.git/blame - busybox.spec
- updated printf-gettext,insmod-morearchs patches
[packages/busybox.git] / busybox.spec
CommitLineData
2678f462
JB
1#
2# Conditional build:
b5011fd7 3# alternative busybox config file (replaces default one) you should
4a69c6c5 4# define cfgfile macro, i.e.
d635bde0 5#
6# rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
2678f462
JB
7%bcond_with altconfig # use alternative config (defined by cfgfile)
8%bcond_with linkfl # creates links to busybox binary and puts them into file list
d635bde0 9# Options below are useful, when you want fileutils and grep providing.
10# For example, ash package requires fileutils and grep.
2678f462
JB
11%bcond_with fileutl_prov # adds fileutils providing
12%bcond_with grep_prov # adds grep providing
d635bde0 13# Option below is useful, when busybox is built with shell support.
2678f462 14%bcond_with sh_prov # adds /bin/sh providing
d635bde0 15# WARNING! Shell, filetuils and grep providing may depend on config file!
16# Fileutils, grep and shell provided with busybox have not such
17# functionality as their GNU countenders.
2678f462
JB
18#
19%bcond_without static # don't build static version
20%bcond_without initrd # don't build initrd version
21%bcond_with dietlibc # build dietlibc-based initrd version
22%bcond_with glibc # build glibc-based initrd version
23#
6714aad6 24%ifnarch %{ix86}
1735ff25
MM
25%define with_glibc 1
26%endif
ee61dafa 27Summary: Set of common unix utils for embeded systems
b7f899e9 28