]> git.pld-linux.org Git - packages/busybox.git/blame - busybox.spec
- patches from upstream
[packages/busybox.git] / busybox.spec
CommitLineData
e7982b05 1# TODO:
a54ace54
CM
2# - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3# if it still serves a purpose
4# - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5# - make internal commands work even if busybox is not in /bin/busybox (initrd)
6# or when /proc is not mounted (static / normal)
598da0d3 7#
2678f462 8# Conditional build:
b5011fd7 9# alternative busybox config file (replaces default one) you should
4a69c6c5 10# define cfgfile macro, i.e.
d635bde0 11#
6f6b5afa 12# rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
a54ace54 13#
2678f462
JB
14%bcond_with altconfig # use alternative config (defined by cfgfile)
15%bcond_with linkfl # creates links to busybox binary and puts them into file list
63de0802 16%bcond_without dynamic # don't build dynamic (base) version
3637c580
JR
17%bcond_without static # don't build static version
18%bcond_without initrd # don't build initrd version
19%bcond_with dietlibc # build dietlibc-based initrd and static versions
20%bcond_with glibc # build glibc-based initrd and static versions
21%bcond_with verbose # verbose build
d635bde0 22# Options below are useful, when you want fileutils and grep providing.
23# For example, ash package requires fileutils and grep.
2678f462
JB
24%bcond_with fileutl_prov # adds fileutils providing
25%bcond_with grep_prov # adds grep providing
d635bde0 26# Option below is useful, when busybox is built with shell support.
2678f462 27%bcond_with sh_prov # adds /bin/sh providing
6b50dd3e 28# WARNING! Shell, fileutils and grep providing may depend on config file!
d635bde0 29# Fileutils, grep and shell provided with busybox have not such
30# functionality as their GNU countenders.
2678f462 31#
c15e3058 32%ifnarch %{ix86} %{x8664} ppc
1735ff25
MM
33%define with_glibc 1
34%endif
dce89576 35Summary: Set of common Unix utilities for embeded systems
718bff43
ER
36Summary(pl.UTF-8): Zestaw narzędzi uniksowych dla systemów wbudowanych
37Summary(pt_BR.UTF-8): BusyBox é um conjunto de utilitários UNIX em um único binário
ee61dafa 38Name: busybox
586f52e3 39# stable line only
f09c9812 40Version: 1.19.2
ffc09670 41Release: 1
bbbc183d 42License: GPL v2
d79d7625 43Group: Applications
693dc2a0 44Source0: http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
f09c9812 45# Source0-md5: 50267054345f1a0b77fe65f6e0e5ba29
4f8fe04f
AM
46Source1: %{name}.config
47Source2: %{name}-initrd.config
8f98fac8 48%{?with_altconfig:Source3: %{cfgfile}}
f09c9812
AM
49Patch100: busybox-1.19.2-android.patch
50Patch101: busybox-1.19.2-buildsys.patch
51Patch102: busybox-1.19.2-chpasswd.patch
52Patch103: busybox-1.19.2-crond.patch
53Patch104: busybox-1.19.2-inetd.patch
54Patch105: busybox-1.19.2-syslogd.patch
55Patch106: busybox-1.19.2-tail.patch
56Patch107: busybox-1.19.2-tftp.patch
b2b9509f 57Patch1: %{name}-logconsole.patch
58Patch2: %{name}-printf-gettext.patch
59Patch3: %{name}-loadfont.patch
29a4a582
JR
60Patch4: %{name}-kernel_headers.patch
61Patch5: %{name}-insmod-morearchs.patch
62Patch6: %{name}-dhcp.patch
63Patch7: %{name}-fix_64_archs.patch
29a4a582 64Patch9: %{name}-ash-export-PATH.patch
87902b66 65URL: http://www.busybox.net/
255676bf 66BuildRequires: gcc >= 3.2
839c36a5 67BuildRequires: perl-tools-pod
02cf2722 68BuildRequires: rpmbuild(macros) >= 1.333
ef0df9c1 69%if %{with initrd} || %{with static}
6f6b5afa 70 %if %{with dietlibc}
1735ff25 71BuildRequires: dietlibc-static
6f6b5afa 72 %else
73 %if %{with glibc}
1735ff25 74BuildRequires: glibc-static
6f6b5afa 75 %else
9922ba41 76%if "%{_target_base_arch}" != "%{_arch}"
77BuildRequires: cross%{_target_base_arch}-uClibc-static
9a45af3a 78%else
9922ba41 79 %ifarch ppc %{x8664}
c574afd9 80BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 81 %else
c574afd9 82BuildRequires: uClibc-static >= 3:0.9.30.1
9922ba41 83 %endif
9a45af3a 84%endif
6f6b5afa 85 %endif
86 %endif
1735ff25 87%endif
a54ace54 88%{?with_sh_prov:Provides: /bin/sh}
2678f462
JB
89%{?with_fileutl_prov:Provides: fileutils}
90%{?with_grep_prov:Provides: grep}
ee61dafa
MM
91BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
e7982b05 93%define _bindir /bin
fc11b50f 94
9922ba41 95%if "%{_target_base_arch}" != "%{_arch}"
96 %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
97%else
98 %define CrossOpts %{nil}
99%endif
100
558ca139
JR
101%define filterout_ld -Wl,-z,(combreloc|relro)
102
ee61dafa 103%description
65512310 104BusyBox combines tiny versions of many common UNIX utilities into a
105single small executable. It provides minimalist replacements for most
106of the utilities you usually find in fileutils, shellutils, findutils,
107textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
108POSIX environment for any small or embedded system. The utilities in
109BusyBox generally have fewer options than their full-featured GNU
110cousins; however, the options that are included provide the expected
111functionality and behave very much like their GNU counterparts.
112
113BusyBox has been written with size-optimization and limited resources
114in mind. It is also extremely modular so you can easily include or
115exclude commands (or features) at compile time. This makes it easy to
116customize your embedded systems. To create a working system, just add
117a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
118ae).
ee61dafa 119
c499e458
JR
120%description -l pl.UTF-8
121BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
122wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
b7f899e9 123zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
c499e458
JR
124tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
125lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
126odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
b7f899e9
JB
127systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
128(np. elvis-tiny albo ae).
129
c499e458
JR
130%description -l pt_BR.UTF-8
131BusyBox combina versões reduzidas de muitos utilitários UNIX num único
132executável, fornecendo substitutos minimalistas para muitos dos
133executáveis encontrados em pacotes como fileutils, shellutils,
134findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
135em geral têm menos opções que os utilitários GNU, mas as opções
68092394 136implementadas comportam-se de maneira similar aos equivalentes GNU.
137
34ec6041
JB
138%package static
139Summary: Static busybox
718bff43 140Summary(pl.UTF-8): Statycznie skonsolidowany busybox
34ec6041 141Group: Applications
34ec6041
JB
142
143%description static
144Static busybox.
145
c499e458 146%description static -l pl.UTF-8
dfafd31f 147Statycznie skonsolidowany busybox.
34ec6041 148
52db7bd4
MM
149%package initrd
150Summary: Static busybox for initrd
718bff43 151Summary(pl.UTF-8): Statycznie skonsolidowany busybox dla initrd
11aa4d91 152Group: Base
1857f402 153Conflicts: geninitrd < 10000.20
52db7bd4
MM
154
155%description initrd
156Static busybox for initrd.
157
c499e458 158%description initrd -l pl.UTF-8
dfafd31f 159Statycznie skonsolidowany busybox dla initrd.
52db7bd4 160
ee61dafa 161%prep
693dc2a0 162%setup -q
f09c9812
AM
163%patch100 -p1
164%patch101 -p1
165%patch102 -p1
166%patch103 -p1
167%patch104 -p1
168%patch105 -p1
169%patch106 -p1
170%patch107 -p1
171
0b555ee8
JB
172%patch1 -p1
173%patch2 -p1
a54ace54 174#%patch3 -p1
0cf45dc5 175%patch4 -p1
0b555ee8 176%patch5 -p1
5a7abf9a 177%patch6 -p1
0b555ee8 178%patch7 -p1
586f52e3 179%patch9 -p1
ea0cda84 180
ee61dafa 181%build
839c36a5 182install -d built
52db7bd4 183%if %{with initrd}
4f8fe04f
AM
184install %{SOURCE2} .config
185%{__make} oldconfig
52db7bd4 186%{__make} \
91a4c8e3 187 %{?with_verbose:V=1} \
95f61a42 188 CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
63de0802 189 LDFLAGS="%{rpmldflags} -static" \
27ca3ce9 190%if %{with dietlibc}
52db7bd4 191 LIBRARIES="-lrpc" \
661e2e64 192 CC="diet %{__cc}"
1735ff25
MM
193%else
194%if %{with glibc}
9922ba41 195 %{CrossOpts} \
1735ff25 196 CC="%{__cc}"
27ca3ce9 197%else
a54ace54 198 %if "%{_target_base_arch}" != "%{_arch}"
9922ba41 199 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 200 %endif
27ca3ce9
AM
201 CC="%{_target_cpu}-uclibc-gcc"
202%endif
1735ff25
MM
203%endif
204
839c36a5 205mv -f busybox built/busybox.initrd
52db7bd4 206%{__make} clean
52db7bd4
MM
207%endif
208
1735ff25
MM
209%if %{with altconfig}
210install %{SOURCE3} .config
13fc95fb
ER
211%else
212install %{SOURCE1} .config
1735ff25
MM
213%endif
214
4a69c6c5 215%if %{with static}
4f8fe04f 216%{__make} oldconfig
6f6b5afa 217%{__make} \
91a4c8e3 218 %{?with_verbose:V=1} \
ef0df9c1 219 CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
63de0802 220 LDFLAGS="%{rpmldflags} -static" \
ef0df9c1
JR
221%if %{with dietlibc}
222 LIBRARIES="-lrpc" \
661e2e64 223 CC="diet %{__cc}"
ef0df9c1
JR
224%else
225%if %{with glibc}
226 %{CrossOpts} \
52db7bd4 227 CC="%{__cc}"
ef0df9c1 228%else
a54ace54 229 %if "%{_target_base_arch}" != "%{_arch}"
ef0df9c1 230 CROSS="%{_target_cpu}-uclibc-" \
a54ace54 231 %endif
ef0df9c1
JR
232 CC="%{_target_cpu}-uclibc-gcc"
233%endif
234%endif
235
839c36a5 236mv -f busybox built/busybox.static
2481202a 237%{__make} clean
34ec6041 238%endif
2481202a 239
63de0802 240%if %{with dynamic}
b5011fd7 241%{__make} oldconfig
b7f899e9 242%{__make} \
91a4c8e3 243 %{?with_verbose:V=1} \
9922ba41 244 %{CrossOpts} \
b7f899e9 245 CFLAGS_EXTRA="%{rpmcflags}" \
63de0802 246 LDFLAGS="%{rpmldflags}" \
f5ad7fd6 247 CC="%{__cc}"
bf1f4257 248%{__make} busybox.links docs/busybox.1
63de0802 249%endif
4e2ab1f5 250
ee61dafa
MM
251%install
252rm -rf $RPM_BUILD_ROOT
b7f899e9 253
63de0802
JB
254%if %{with static}
255install -d $RPM_BUILD_ROOT%{_bindir}
256install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
257%endif
258
a71afd72
JR
259%if %{with initrd}
260install -d $RPM_BUILD_ROOT%{_libdir}/initrd
1857f402 261install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
a71afd72 262%endif
34ec6041 263
63de0802
JB
264%if %{with dynamic}
265install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
b7f899e9 266install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
bf1f4257 267install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
ee61dafa 268
d635bde0 269# install links to busybox binary, when linkfl is defined
4a69c6c5 270%if %{with linkfl}
2678f462 271%{__make} install \
5a7abf9a 272 PREFIX=$RPM_BUILD_ROOT
4a69c6c5
MM
273%else
274install busybox $RPM_BUILD_ROOT%{_bindir}
275%endif
63de0802 276%endif
d635bde0 277
ee61dafa
MM
278%clean
279rm -rf $RPM_BUILD_ROOT
280
63de0802 281%if %{with dynamic}
ee61dafa
MM
282%files
283%defattr(644,root,root,755)
a230e0df 284%doc AUTHORS README .config
d635bde0 285
4a69c6c5 286%if %{with linkfl}
a54ace54 287%attr(755,root,root) %{_bindir}/*
d635bde0 288%attr(755,root,root) /sbin/*
289%attr(755,root,root) %{_bindir}/*
290%attr(755,root,root) %{_sbindir}/*
4a69c6c5
MM
291%else
292%attr(755,root,root) %{_bindir}/busybox
d635bde0 293%endif
294
65512310 295%{_libdir}/busybox
296%{_mandir}/man1/*
63de0802 297%endif
bb4ca08e 298
4a69c6c5 299%if %{with static}
34ec6041
JB
300%files static
301%defattr(644,root,root,755)
302%attr(755,root,root) %{_bindir}/busybox.static
303%endif
52db7bd4
MM
304
305%if %{with initrd}
306%files initrd
307%defattr(644,root,root,755)
1857f402 308%attr(755,root,root) %{_libdir}/initrd/busybox
52db7bd4 309%endif
This page took 0.282868 seconds and 4 git commands to generate.