]> git.pld-linux.org Git - packages/bugzilla.git/blame - bugzilla.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/bugzilla.git] / bugzilla.spec
CommitLineData
cfd1a589
ER
1# TODO
2# - Split DB packages for mysql/pgsql
3# - fill brr and add autodeps bcond
8274a9bf 4Summary: Bug tracking system
59e2cd84 5Summary(pl.UTF-8): System śledzenia błędów
8274a9bf 6Name: bugzilla
62e780f5 7Version: 3.3.3
a2979f52 8Release: 0.1
8274a9bf 9License: GPL
29309029 10Group: Applications/WWW
f59432ca 11Source0: http://ftp.mozilla.org/pub/mozilla.org/webtools/%{name}-%{version}.tar.gz
62e780f5 12# Source0-md5: 893273266255f15e5b253719e8abcb50
b27983c1
ER
13Source1: %{name}-skins.tar.bz2
14# Source1-md5: 4e6e8c2b65cab635975eff5ab318057b
15Source2: %{name}.conf
16Source3: %{name}-localconfig.pl
17Source4: %{name}.cron
6f24946d 18Patch0: %{name}-pld.patch
8274a9bf 19URL: http://www.bugzilla.org/
52df0c76
PG
20# http://www.bugzilla.org/security/3.2.2/
21BuildRequires: security(3.2.2)
90c1b784 22BuildRequires: rpm-perlprov >= 4.1-13
ce824031 23BuildRequires: rpmbuild(macros) >= 1.268
3e50bea3 24BuildRequires: sed >= 4.0
f59432ca
ER
25Requires: perl(Email::MIME::Modifier)
26Requires: perl(Email::Send) >= 2.00
8274a9bf 27Requires: perl-DBD-mysql
2ffbd3ad 28Requires: perl-DBI >= 1.41
6f24946d 29Requires: perl-MailTools >= 1.67
cfd1a589 30Requires: smtpdaemon
bd1423d3 31Requires: webapps
cfd1a589 32BuildArch: noarch
8274a9bf
TO
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
bd1423d3
ER
35%define _webapps /etc/webapps
36%define _webapp %{name}
37%define _sysconfdir %{_webapps}/%{_webapp}
38%define _appdir %{_datadir}/%{_webapp}
d15bced7 39# Don't enforce DBD driver and exclude optional packages according to release notes
2ffbd3ad
ER
40%define _noautoreq 'perl(DBD::.*)' perl(Chart::Base) perl(GD) perl(GD::Graph) perl(GD::Text::Align) perl(Net::LDAP) perl(PatchReader) perl(XML::Twig) perl(Image::Magick)
41
42#D perl-Apache-DBI-1.01-1, perl-AppConfig-1.56-2, perl-BSD-Resource-1.28-1, perl-Class-Inspector-1.16-1,
43#D perl-DBD-Pg-1.49-1, perl-Data-Flow-0.09-2, perl-Email-Abstract-2.13-1, perl-Email-Address-1.86-1,
44#D perl-Email-MIME-1.85-1, perl-Email-MIME-Attachment-Stripper-1.3-1, perl-Email-MIME-ContentType-1.0-1,
45#D perl-Email-MIME-Creator-1.45-1, perl-Email-MIME-Encodings-1.3-2, perl-Email-MIME-Modifier-1.43-1,
46#D perl-Email-MessageID-1.35-1, perl-Email-Reply-1.1-1, perl-Email-Send-1.46-1, perl-Email-Simple-1.96-1,
47#D perl-Email-Simple-Creator-1.41-1, perl-IO-All-0.33-2, perl-IO-String-1.08-1, perl-Module-Pluggable-3.1-4,
48#D perl-Return-Value-1.28-1, perl-Spiffy-0.30-1, perl-Template-Toolkit-2.15-1, perl-mixin-0.04-1, perl-mod_perl-2.0.3-2
49
8274a9bf
TO
50
51%description
cfd1a589 52Bugzilla is the Bug-Tracking System from the Mozilla project.
8274a9bf 53
b31e80bd
JR
54%description -l pl.UTF-8
55System śledzenia błędów.
8274a9bf
TO
56
57%prep
b27983c1 58%setup -q %{?_rc:-n %{name}-%{version}%{_rc}} -a1
a8d6ba6e 59%patch0 -p1
6f24946d
ER
60
61sed -i -e '
62s,use lib ".",use lib "%{_appdir}",
63s,use lib qw(.),use lib "%{_appdir}",
64' *.cgi
8274a9bf 65
cfd1a589
ER
66find -name CVS -type d | xargs rm -rf
67find '(' -name '*~' -o -name '*.orig' -o -name '.cvsignore' ')' | xargs -r rm -v
8274a9bf 68
6f24946d
ER
69# won't package tests
70rm -f runtests.pl
71
8274a9bf
TO
72%install
73rm -rf $RPM_BUILD_ROOT
6f24946d
ER
74install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/htdocs,/var/lib/%{name}/{data,graphs}} \
75 $RPM_BUILD_ROOT%{perl_vendorlib}
76
77install *.pl $RPM_BUILD_ROOT%{_appdir}
78cp -a template $RPM_BUILD_ROOT%{_appdir}
79cp -a Bugzilla{,.pm} $RPM_BUILD_ROOT%{perl_vendorlib}
8274a9bf 80
62e780f5 81install *.{cgi,txt,dtd} js/*.js $RPM_BUILD_ROOT%{_appdir}/htdocs
6f24946d 82cp -a images js skins $RPM_BUILD_ROOT%{_appdir}/htdocs
8274a9bf 83
6f24946d 84ln -s /var/lib/%{name}/graphs $RPM_BUILD_ROOT%{_appdir}/htdocs
a8d6ba6e 85
b27983c1
ER
86install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
87install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
88install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/localconfig.pl
89install -D %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.daily/bugzilla
8274a9bf
TO
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
6f24946d
ER
94%post
95if [ "$1" = 1 ]; then
4ff49655
ER
96# shamelessly stolen from gentoo
97%banner -e %{name} <<'EOF'
980. Bugzilla has been installed into %{_appdir}
99
1001. To finish the installation, please read
101 http://www.bugzilla.org/docs/%{version}/html/installation.html
102 You will need to run %{_appdir}/checksetup.pl
103
104 IMPORTANT: If you have customized the values in your
105 Status/Resolution field, you must edit checksetup.pl BEFORE YOU RUN
106 IT. Please see the Release Notes for more details.
107
1082. Please read the Release Notes, especially if you are upgrading:
109 http://www.bugzilla.org/releases/%{version}/release-notes.html
6f24946d
ER
110EOF
111fi
112
04eebeb6 113%triggerin -- apache1 < 1.3.37-3, apache1-base
bd1423d3
ER
114%webapp_register apache %{_webapp}
115
04eebeb6 116%triggerun -- apache1 < 1.3.37-3, apache1-base
bd1423d3
ER
117%webapp_unregister apache %{_webapp}
118
119%triggerin -- apache < 2.2.0, apache-base
120%webapp_register httpd %{_webapp}
121
122%triggerun -- apache < 2.2.0, apache-base
123%webapp_unregister httpd %{_webapp}
8274a9bf
TO
124
125%files
126%defattr(644,root,root,755)
62e780f5 127%doc QUICKSTART README UPGRADING* docs/en/rel_notes.txt docs/en/txt/Bugzilla-Guide.txt
128%doc contrib docs/en/html
bd1423d3 129%dir %attr(750,root,http) %{_sysconfdir}
cfd1a589 130%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
bd1423d3 131%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
d15bced7 132%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.pl
bd1423d3 133
4ff49655
ER
134%attr(755,root,root) /etc/cron.daily/bugzilla
135
6f24946d
ER
136%{perl_vendorlib}/Bugzilla
137%{perl_vendorlib}/Bugzilla.pm
138
bd1423d3 139%dir %{_appdir}
bd1423d3 140%{_appdir}/template
b27983c1
ER
141%attr(700,root,root) %{_appdir}/checksetup.pl
142%attr(755,root,root) %{_appdir}/collectstats.pl
143%attr(755,root,root) %{_appdir}/email_in.pl
144%attr(755,root,root) %{_appdir}/importxml.pl
62e780f5 145%attr(755,root,root) %{_appdir}/install-module.pl
146%attr(755,root,root) %{_appdir}/jobqueue.pl
b27983c1 147%attr(755,root,root) %{_appdir}/mod_perl.pl
62e780f5 148%attr(755,root,root) %{_appdir}/sanitycheck.pl
b27983c1
ER
149%attr(755,root,root) %{_appdir}/testserver.pl
150%attr(755,root,root) %{_appdir}/whine.pl
151%attr(755,root,root) %{_appdir}/whineatnews.pl
6f24946d
ER
152
153%dir %{_appdir}/htdocs
b27983c1 154%attr(755,root,root) %{_appdir}/htdocs/*.cgi
6f24946d
ER
155%{_appdir}/htdocs/*.dtd
156%{_appdir}/htdocs/*.js
157%{_appdir}/htdocs/*.txt
6f24946d
ER
158%{_appdir}/htdocs/graphs
159%{_appdir}/htdocs/images
160%{_appdir}/htdocs/js
b27983c1
ER
161%dir %{_appdir}/htdocs/skins
162%dir %{_appdir}/htdocs/skins/contrib
62e780f5 163%dir %{_appdir}/htdocs/skins/contrib/Dusk
b27983c1
ER
164%dir %{_appdir}/htdocs/skins/custom
165%{_appdir}/htdocs/skins/standard
166%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_appdir}/htdocs/skins/custom/*.css
62e780f5 167%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_appdir}/htdocs/skins/contrib/Dusk/*.css
6f24946d 168
a8d6ba6e
TO
169%dir /var/lib/%{name}
170%attr(770,root,http) /var/lib/%{name}/data
6f24946d 171%attr(770,root,http) /var/lib/%{name}/graphs
This page took 0.108607 seconds and 5 git commands to generate.