]> git.pld-linux.org Git - packages/bugzilla.git/blame - bugzilla.spec
- up to 2.22.2
[packages/bugzilla.git] / bugzilla.spec
CommitLineData
cfd1a589
ER
1# TODO
2# - Split DB packages for mysql/pgsql
3# - fill brr and add autodeps bcond
8274a9bf
TO
4%include /usr/lib/rpm/macros.perl
5Summary: Bug tracking system
59e2cd84 6Summary(pl.UTF-8): System śledzenia błędów
8274a9bf 7Name: bugzilla
093a9f9f
ER
8Version: 2.22.1
9Release: 0.32
8274a9bf 10License: GPL
29309029 11Group: Applications/WWW
cfd1a589 12Source0: http://ftp.mozilla.org/pub/mozilla.org/webtools/%{name}-%{version}.tar.gz
093a9f9f 13# Source0-md5: d52e2818441f3c2a5caeddf6c40b9f00
8274a9bf 14Source1: %{name}.conf
6f24946d 15Source2: %{name}-localconfig.pl
4ff49655 16Source3: %{name}.cron
6f24946d 17Patch0: %{name}-pld.patch
8274a9bf 18URL: http://www.bugzilla.org/
ce824031 19BuildRequires: rpmbuild(macros) >= 1.268
3e50bea3 20BuildRequires: sed >= 4.0
8274a9bf 21Requires: perl-DBD-mysql
29309029 22Requires: perl-DBI >= 1.36
6f24946d 23Requires: perl-MailTools >= 1.67
cfd1a589 24Requires: smtpdaemon
bd1423d3 25Requires: webapps
cfd1a589 26BuildArch: noarch
8274a9bf
TO
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
bd1423d3
ER
29%define _webapps /etc/webapps
30%define _webapp %{name}
31%define _sysconfdir %{_webapps}/%{_webapp}
32%define _appdir %{_datadir}/%{_webapp}
d15bced7
ER
33# Don't enforce DBD driver and exclude optional packages according to release notes
34%define _noautoreq 'perl(DBD::*)' perl(Chart::Base) perl(GD) perl(GD::Graph) perl(GD::Text::Align) perl(Net::LDAP) perl(PatchReader) perl(XML::Twig) perl(Image::Magick)
8274a9bf
TO
35
36%description
cfd1a589 37Bugzilla is the Bug-Tracking System from the Mozilla project.
8274a9bf 38
b31e80bd
JR
39%description -l pl.UTF-8
40System śledzenia błędów.
8274a9bf
TO
41
42%prep
cfd1a589 43%setup -q
a8d6ba6e 44%patch0 -p1
6f24946d
ER
45
46sed -i -e '
47s,use lib ".",use lib "%{_appdir}",
48s,use lib qw(.),use lib "%{_appdir}",
49' *.cgi
8274a9bf 50
cfd1a589
ER
51find -name CVS -type d | xargs rm -rf
52find '(' -name '*~' -o -name '*.orig' -o -name '.cvsignore' ')' | xargs -r rm -v
8274a9bf 53
6f24946d
ER
54# won't package tests
55rm -f runtests.pl
56
8274a9bf
TO
57%install
58rm -rf $RPM_BUILD_ROOT
6f24946d
ER
59install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/htdocs,/var/lib/%{name}/{data,graphs}} \
60 $RPM_BUILD_ROOT%{perl_vendorlib}
61
62install *.pl $RPM_BUILD_ROOT%{_appdir}
63cp -a template $RPM_BUILD_ROOT%{_appdir}
64cp -a Bugzilla{,.pm} $RPM_BUILD_ROOT%{perl_vendorlib}
8274a9bf 65
6f24946d
ER
66install *.{cgi,js,txt,dtd,xul} $RPM_BUILD_ROOT%{_appdir}/htdocs
67cp -a images js skins $RPM_BUILD_ROOT%{_appdir}/htdocs
8274a9bf 68
6f24946d 69ln -s /var/lib/%{name}/graphs $RPM_BUILD_ROOT%{_appdir}/htdocs
a8d6ba6e 70
cfd1a589 71install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
bd1423d3 72install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
6f24946d 73install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/localconfig.pl
4ff49655 74install -D %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.daily/bugzilla
8274a9bf
TO
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
6f24946d
ER
79%post
80if [ "$1" = 1 ]; then
4ff49655
ER
81# shamelessly stolen from gentoo
82%banner -e %{name} <<'EOF'
830. Bugzilla has been installed into %{_appdir}
84
851. To finish the installation, please read
86 http://www.bugzilla.org/docs/%{version}/html/installation.html
87 You will need to run %{_appdir}/checksetup.pl
88
89 IMPORTANT: If you have customized the values in your
90 Status/Resolution field, you must edit checksetup.pl BEFORE YOU RUN
91 IT. Please see the Release Notes for more details.
92
932. Please read the Release Notes, especially if you are upgrading:
94 http://www.bugzilla.org/releases/%{version}/release-notes.html
6f24946d
ER
95EOF
96fi
97
04eebeb6 98%triggerin -- apache1 < 1.3.37-3, apache1-base
bd1423d3
ER
99%webapp_register apache %{_webapp}
100
04eebeb6 101%triggerun -- apache1 < 1.3.37-3, apache1-base
bd1423d3
ER
102%webapp_unregister apache %{_webapp}
103
104%triggerin -- apache < 2.2.0, apache-base
105%webapp_register httpd %{_webapp}
106
107%triggerun -- apache < 2.2.0, apache-base
108%webapp_unregister httpd %{_webapp}
8274a9bf
TO
109
110%files
111%defattr(644,root,root,755)
d15bced7 112%doc QUICKSTART README UPGRADING* docs/rel_notes.txt docs/txt/Bugzilla-Guide.txt
cfd1a589 113%doc contrib docs/html
bd1423d3 114%dir %attr(750,root,http) %{_sysconfdir}
cfd1a589 115%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
bd1423d3 116%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
d15bced7 117%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.pl
bd1423d3 118
4ff49655
ER
119%attr(755,root,root) /etc/cron.daily/bugzilla
120
6f24946d
ER
121%{perl_vendorlib}/Bugzilla
122%{perl_vendorlib}/Bugzilla.pm
123
bd1423d3 124%dir %{_appdir}
bd1423d3 125%{_appdir}/template
6f24946d
ER
126%attr(755,root,root) %{_appdir}/*.pl
127
128%dir %{_appdir}/htdocs
129%{_appdir}/htdocs/*.dtd
130%{_appdir}/htdocs/*.js
131%{_appdir}/htdocs/*.txt
132%{_appdir}/htdocs/*.xul
133%{_appdir}/htdocs/graphs
134%{_appdir}/htdocs/images
135%{_appdir}/htdocs/js
136%{_appdir}/htdocs/skins
137%attr(755,root,root) %{_appdir}/htdocs/*.cgi
138
a8d6ba6e
TO
139%dir /var/lib/%{name}
140%attr(770,root,http) /var/lib/%{name}/data
6f24946d 141%attr(770,root,http) /var/lib/%{name}/graphs
This page took 0.041505 seconds and 4 git commands to generate.