]> git.pld-linux.org Git - packages/bugzilla.git/blame - bugzilla.spec
- 2.22.2
[packages/bugzilla.git] / bugzilla.spec
CommitLineData
cfd1a589
ER
1# TODO
2# - Split DB packages for mysql/pgsql
3# - fill brr and add autodeps bcond
8274a9bf
TO
4%include /usr/lib/rpm/macros.perl
5Summary: Bug tracking system
59e2cd84 6Summary(pl.UTF-8): System śledzenia błędów
8274a9bf 7Name: bugzilla
90c1b784
ER
8Version: 2.22.2
9Release: 0.1
8274a9bf 10License: GPL
29309029 11Group: Applications/WWW
cfd1a589 12Source0: http://ftp.mozilla.org/pub/mozilla.org/webtools/%{name}-%{version}.tar.gz
90c1b784 13# Source0-md5: fb7fdcaacf5efad6f3bd5a1a810c467f
8274a9bf 14Source1: %{name}.conf
6f24946d 15Source2: %{name}-localconfig.pl
4ff49655 16Source3: %{name}.cron
6f24946d 17Patch0: %{name}-pld.patch
8274a9bf 18URL: http://www.bugzilla.org/
90c1b784 19BuildRequires: rpm-perlprov >= 4.1-13
ce824031 20BuildRequires: rpmbuild(macros) >= 1.268
3e50bea3 21BuildRequires: sed >= 4.0
8274a9bf 22Requires: perl-DBD-mysql
29309029 23Requires: perl-DBI >= 1.36
6f24946d 24Requires: perl-MailTools >= 1.67
cfd1a589 25Requires: smtpdaemon
bd1423d3 26Requires: webapps
cfd1a589 27BuildArch: noarch
8274a9bf
TO
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
bd1423d3
ER
30%define _webapps /etc/webapps
31%define _webapp %{name}
32%define _sysconfdir %{_webapps}/%{_webapp}
33%define _appdir %{_datadir}/%{_webapp}
d15bced7
ER
34# Don't enforce DBD driver and exclude optional packages according to release notes
35%define _noautoreq 'perl(DBD::*)' perl(Chart::Base) perl(GD) perl(GD::Graph) perl(GD::Text::Align) perl(Net::LDAP) perl(PatchReader) perl(XML::Twig) perl(Image::Magick)
8274a9bf
TO
36
37%description
cfd1a589 38Bugzilla is the Bug-Tracking System from the Mozilla project.
8274a9bf 39
b31e80bd
JR
40%description -l pl.UTF-8
41System śledzenia błędów.
8274a9bf
TO
42
43%prep
cfd1a589 44%setup -q
a8d6ba6e 45%patch0 -p1
6f24946d
ER
46
47sed -i -e '
48s,use lib ".",use lib "%{_appdir}",
49s,use lib qw(.),use lib "%{_appdir}",
50' *.cgi
8274a9bf 51
cfd1a589
ER
52find -name CVS -type d | xargs rm -rf
53find '(' -name '*~' -o -name '*.orig' -o -name '.cvsignore' ')' | xargs -r rm -v
8274a9bf 54
6f24946d
ER
55# won't package tests
56rm -f runtests.pl
57
8274a9bf
TO
58%install
59rm -rf $RPM_BUILD_ROOT
6f24946d
ER
60install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/htdocs,/var/lib/%{name}/{data,graphs}} \
61 $RPM_BUILD_ROOT%{perl_vendorlib}
62
63install *.pl $RPM_BUILD_ROOT%{_appdir}
64cp -a template $RPM_BUILD_ROOT%{_appdir}
65cp -a Bugzilla{,.pm} $RPM_BUILD_ROOT%{perl_vendorlib}
8274a9bf 66
6f24946d
ER
67install *.{cgi,js,txt,dtd,xul} $RPM_BUILD_ROOT%{_appdir}/htdocs
68cp -a images js skins $RPM_BUILD_ROOT%{_appdir}/htdocs
8274a9bf 69
6f24946d 70ln -s /var/lib/%{name}/graphs $RPM_BUILD_ROOT%{_appdir}/htdocs
a8d6ba6e 71
cfd1a589 72install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
bd1423d3 73install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
6f24946d 74install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/localconfig.pl
4ff49655 75install -D %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.daily/bugzilla
8274a9bf
TO
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
6f24946d
ER
80%post
81if [ "$1" = 1 ]; then
4ff49655
ER
82# shamelessly stolen from gentoo
83%banner -e %{name} <<'EOF'
840. Bugzilla has been installed into %{_appdir}
85
861. To finish the installation, please read
87 http://www.bugzilla.org/docs/%{version}/html/installation.html
88 You will need to run %{_appdir}/checksetup.pl
89
90 IMPORTANT: If you have customized the values in your
91 Status/Resolution field, you must edit checksetup.pl BEFORE YOU RUN
92 IT. Please see the Release Notes for more details.
93
942. Please read the Release Notes, especially if you are upgrading:
95 http://www.bugzilla.org/releases/%{version}/release-notes.html
6f24946d
ER
96EOF
97fi
98
04eebeb6 99%triggerin -- apache1 < 1.3.37-3, apache1-base
bd1423d3
ER
100%webapp_register apache %{_webapp}
101
04eebeb6 102%triggerun -- apache1 < 1.3.37-3, apache1-base
bd1423d3
ER
103%webapp_unregister apache %{_webapp}
104
105%triggerin -- apache < 2.2.0, apache-base
106%webapp_register httpd %{_webapp}
107
108%triggerun -- apache < 2.2.0, apache-base
109%webapp_unregister httpd %{_webapp}
8274a9bf
TO
110
111%files
112%defattr(644,root,root,755)
d15bced7 113%doc QUICKSTART README UPGRADING* docs/rel_notes.txt docs/txt/Bugzilla-Guide.txt
cfd1a589 114%doc contrib docs/html
bd1423d3 115%dir %attr(750,root,http) %{_sysconfdir}
cfd1a589 116%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
bd1423d3 117%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
d15bced7 118%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.pl
bd1423d3 119
4ff49655
ER
120%attr(755,root,root) /etc/cron.daily/bugzilla
121
6f24946d
ER
122%{perl_vendorlib}/Bugzilla
123%{perl_vendorlib}/Bugzilla.pm
124
bd1423d3 125%dir %{_appdir}
bd1423d3 126%{_appdir}/template
6f24946d
ER
127%attr(755,root,root) %{_appdir}/*.pl
128
129%dir %{_appdir}/htdocs
130%{_appdir}/htdocs/*.dtd
131%{_appdir}/htdocs/*.js
132%{_appdir}/htdocs/*.txt
133%{_appdir}/htdocs/*.xul
134%{_appdir}/htdocs/graphs
135%{_appdir}/htdocs/images
136%{_appdir}/htdocs/js
137%{_appdir}/htdocs/skins
138%attr(755,root,root) %{_appdir}/htdocs/*.cgi
139
a8d6ba6e
TO
140%dir /var/lib/%{name}
141%attr(770,root,http) /var/lib/%{name}/data
6f24946d 142%attr(770,root,http) /var/lib/%{name}/graphs
This page took 0.055249 seconds and 4 git commands to generate.