]> git.pld-linux.org Git - packages/bopm.git/blame - bopm.spec
- new
[packages/bopm.git] / bopm.spec
CommitLineData
247723c2
ER
1Summary: Open proxy monitor and blocker, designed for use with ircds
2Name: bopm
3Version: 3.1.2
4Release: 0.10
5Epoch: 0
6License: GPL
7Group: Applications/Communications
8Source0: http://static.blitzed.org/www.blitzed.org/bopm/files/%{name}-%{version}.tar.gz
9# Source0-md5: ab1b7494c4242eef957b5fca61c92b18
10Source1: %{name}.init
11Source2: %{name}.conf
12BuildRequires: rpmbuild(macros) >= 1.202
13Patch0: %{name}-DESTDIR.patch
14URL: http://www.blitzed.org/bopm/
15BuildRequires: automake
16BuildRequires: autoconf
17BuildRequires: libtool
18BuildRequires: findutils
19Requires: rc-scripts
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23The Blitzed Open Proxy Monitor is designed to connect to an IRC server
24and become an IRC operator. It then watches connect notices in order
25to scan all connecting clients for open (insecure) proxies. Such
26insecure proxies are commonly used for spamming, floods and other
27abusive activities.
28
29BOPM can detect WinGates, HTTP proxies, SOCKS 4/5 proxies and Cisco
30routers with default passwords. BOPM also has support for checking
31against a DNS-Based Blacklist (similar to MAPS RBL) and can be
32configured to report new proxies back to the Blitzed Open Proxy
33Monitoring project.
34
35%prep
36%setup -q
37%patch0 -p1
38
39find -name CVS | xargs -r rm -rf
40rm -f contrib/bopm.spec
41
42%build
43%{__libtoolize}
44%{__aclocal}
45%{__autoconf}
46%{__autoheader}
47%{__automake}
48%configure \
49 --localstatedir=/var/log/%{name} \
50 --bindir=%{_sbindir}
51
52%{__make}
53
54%install
55rm -rf $RPM_BUILD_ROOT
56
57install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d,/var/{run,log}/%{name}}
58%{__make} install \
59 DESTDIR=$RPM_BUILD_ROOT
60
61install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
62install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
63> $RPM_BUILD_ROOT/var/log/%{name}/bopm.log
64> $RPM_BUILD_ROOT/var/log/%{name}/scan.log
65
66%clean
67rm -rf $RPM_BUILD_ROOT
68
69%pre
70%groupadd -g 151 %{name}
71%useradd -u 151 -c "BOPM Daemon" -g %{name} %{name}
72
73%post
74/sbin/chkconfig --add %{name}
75if [ -f /var/lock/subsys/%{name} ]; then
76 /etc/rc.d/init.d/%{name} restart 1>&2
77else
78 echo "Run \"/etc/rc.d/init.d/%{name} start\" to start BOPM daemon."
79fi
80
81%preun
82if [ "$1" = "0" ]; then
83 if [ -f /var/lock/subsys/%{name} ]; then
84 /etc/rc.d/init.d/%{name} stop 1>&2
85 fi
86 /sbin/chkconfig --del %{name}
87fi
88
89%files
90%defattr(644,root,root,755)
91%doc ChangeLog INSTALL README bopm.conf.sample
92%doc contrib/ network-bopm/
93%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.conf
94%attr(754,root,root) /etc/rc.d/init.d/%{name}
95%attr(755,root,root) %{_sbindir}/%{name}
96
97%attr(770,root,bopm) %dir /var/run/%{name}
98%attr(770,root,bopm) %dir /var/log/%{name}
99%attr(640,bopm,bopm) %ghost /var/log/%{name}/bopm.log
100%attr(640,bopm,bopm) %ghost /var/log/%{name}/scan.log
This page took 0.095568 seconds and 4 git commands to generate.