]> git.pld-linux.org Git - packages/bash.git/blame - bash.spec
- up to 4.3.27 (it's effectively the same as our 4.3.26-2)
[packages/bash.git] / bash.spec
CommitLineData
b92ff090 1#
cb14c662 2# Conditional build:
a651f1c4
JB
3%bcond_without static # don't build static version
4%bcond_with bash_history # build with additional history in /var/log/bash_hist ;)
e407816c 5%bcond_without tests # do not perform "make test"
4adb4b80 6
37b19da9 7# NOTE: when updating patchleve, do not forget to update 'sources' file!
0c16d439 8%define ver 4.3
3e12ae6a
AM
9%define patchlevel 27
10%define rel 1
7d6d2b69 11Summary: GNU Bourne Again Shell (bash)
dcd748fa
ER
12Summary(fr.UTF-8): Le shell Bourne Again de GNU
13Summary(pl.UTF-8): Powłoka GNU Bourne Again Shell (bash)
7d6d2b69 14Name: bash
03cee40d 15Version: %{ver}%{?patchlevel:.%{patchlevel}}
8bd2c87f 16Release: %{rel}%{?with_bash_history:inv}
4e122b9a 17License: GPL
23ed535f 18Group: Applications/Shells
ec429726 19Source0: http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
0c16d439 20# Source0-md5: 81348932d5da294953e15d4814c74dd1
23ed535f 21Source1: %{name}rc
678800bc
JB
22Source2: %{name}-skel-.bash_logout
23Source3: %{name}-skel-.bash_profile
24Source4: %{name}-skel-.bashrc
df8b9a69 25Source5: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
60c0b40e 26# Source5-md5: d2aacf89c4a444c5da648da69afdb01a
23ed535f 27Patch0: %{name}-paths.patch
070ee007 28Patch1: %{name}-security.patch
29Patch2: %{name}-autoconf.patch
30Patch3: %{name}-info.patch
31Patch4: %{name}-profile.patch
32Patch5: %{name}-requires.patch
33Patch6: %{name}-compat.patch
60c0b40e
JB
34Patch8: %{name}-sighup.patch
35Patch9: %{name}-backup_history.patch
716158f0 36Patch10: %{name}-act_like_sh.patch
232f944c 37Patch11: %{name}-elinks_cont.patch
678800bc 38Patch12: %{name}-pl.po-update.patch
3e12ae6a
AM
39# from FC
40Patch13: bash-4.2-cve-2014-7169-2.patch
0237e5f4 41%patchset_source -f https://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-%03g 1 %{patchlevel}
8cdc40d7 42URL: http://www.gnu.org/software/bash/
0422a072 43BuildRequires: autoconf
c0ebe85a 44BuildRequires: automake
0422a072 45BuildRequires: bison
de477a4d 46BuildRequires: ncurses-devel >= 5.2
0c16d439 47BuildRequires: readline-devel >= 6.3
41a1b1c8 48BuildRequires: rpmbuild(macros) >= 1.462
ccf2597d 49BuildRequires: sed >= 4.0
6b611e4d 50BuildRequires: texinfo
cf6e8919 51%if %{with static}
de477a4d 52# Require static library only for static build
0422a072 53BuildRequires: glibc-static >= 2.2
4e122b9a 54BuildRequires: ncurses-static >= 5.2
0c16d439 55BuildRequires: readline-static >= 6.3
de477a4d 56%endif
0c16d439 57Requires: readline >= 6.3
0c55bbdc 58Requires: setup >= 2.4.6-2
0b28b541 59Obsoletes: bash-doc
f40d50c2 60Obsoletes: bash2
61Obsoletes: bash2-doc
0b28b541 62Obsoletes: etcskel
60c0b40e 63BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67581caa 64
65%description
001c539f 66Bash is a GNU project sh-compatible shell or command language
67interpreter. Bash (Bourne Again shell) incorporates useful features
68from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
69be run by bash without modification. Bash offers several improvements
70over sh, including command line editing, unlimited size command
71history, job control, shell functions and aliases, indexed arrays of
72unlimited size and integer arithmetic in any base from two to 64. Bash
73is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
74Shell and Tools standard. Bash is the default shell for Linux
75Mandrake. You should install bash because of its popularity and power.
76You'll probably end up using it.
a3871122 77
ef6e8bca 78%description -l es.UTF-8
1d0ad239 79Bash es un interpretador de comandos compatible con sh, que ejecuta
ef6e8bca
JR
80comandos leídos de la entrada padrón o de un archivo. Bash también
81incorpora características útiles de las shells Korn y C (ksh y csh).
82Bash ha sido desarrollado para ser una adición compatible con la
83especificación IEEE Posix para shells y herramientas (IEEE Working
1d0ad239 84Group 1003.2).
85
ef6e8bca 86%description -l de.UTF-8
001c539f 87Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
ef6e8bca 88GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
001c539f 89Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
ef6e8bca 90sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
001c539f 91Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
ef6e8bca
JR
92Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
93Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
001c539f 94indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
95Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
ef6e8bca 96und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
8a4ad51c 97Mandrake.
a3871122 98
ef6e8bca
JR
99%description -l fr.UTF-8
100Bash est un shell (interpréteur de commande) du projet GNU, compatible
001c539f 101avec le shell historique sh. Bash (Bourne Again SHell) comprend de
ef6e8bca
JR
102nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
103plupart des scripts sh sont exécutables sans modifications. Bash
104comprend nombre d'améliorations par rapport à sh : édition de la ligne
105de commande, historique illimité, contrôle des processus
106d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
107illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
001c539f 10864. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
ef6e8bca
JR
109and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
110l'installer du fait de sa puissance et de sa popularité. Vous finirez
001c539f 111probablement par l'utiliser.
7d6d2b69 112
ef6e8bca
JR
113%description -l pl.UTF-8
114Bash (Bourne Again SHell) jest projektem GNU powłoki kompatybilnej z
115sh oraz interpretera języka poleceń. Posiada użyteczne właściwości
116powłok Korn (ksh) i C (csh). Większość skryptów sh może być
117uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeń w
118stosunku do sh, włączając edycję linii poleceń, nieograniczony rozmiar
119historii poleceń, funkcje i aliasy, indeksowane tablice
120nieograniczonych rozmiarów oraz arytmetykę całkowitoliczbową o
121dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma być zgodny
4d6d135d 122ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
67581caa 123
ef6e8bca
JR
124%description -l pt_BR.UTF-8
125Bash é um interpretador de comandos compatível com sh, que executa
126comandos lidos da entrada padrão ou de um arquivo. Bash também
127incorpora características úteis das shells Korn e C (ksh e csh). Bash
128tem sido desenvolvido para ser uma implementação compatível com a
129especificação IEEE Posix para shells e ferramentas (IEEE Working Group
1d0ad239 1301003.2).
131
ef6e8bca
JR
132%description -l ru.UTF-8
133Bash - это sh-совместимый интерпретатор командного языка (shell),
134исполняющий команды, поступающие со стандартного ввода или из файла.
135Bash включает полезные расширения из интерпретаторов Korn и C shell
136(ksh и csh).
1d0ad239 137
ef6e8bca 138Bash разрабатывается как реализация, отвечающая IEEE Posix Shell and
1d0ad239 139Tools specification (IEEE Working Group 1003.2).
140
ef6e8bca
JR
141%description -l tr.UTF-8
142Bash standart girişten ya da bir dosyadan komut okuyup çalıştıran sh
143uyumlu bir komut dili yorumlayıcısıdır. Aynı zamanda Korn ve C
144kabuklarının (ksh ve csh) kullanışlı özelliklerini de kapsar. Bash,
145IEEE Posix Kabuk ve Araç ayrıntılarına (IEEE Working Group 1003.2)
146uyumlu bir uygulama olarak tasarlanmıştır.
67581caa 147
ef6e8bca
JR
148%description -l uk.UTF-8
149Bash - це sh-сумістний інтерпретатор командної мови (shell),
150виконуючий команди зі стандартного вводу або з файла. Bash містить
151користні розширення з інтерпретаторів Korn та C shell (ksh та csh).
1d0ad239 152
ef6e8bca 153Bash розроблявся як реалізація, що відповідає IEEE Posix Shell and
1d0ad239 154Tools specification (IEEE Working Group 1003.2).
155
4f62851f 156%package static
0d32bda9 157Summary: Statically linked GNU Bourne Again Shell (bash)
dcd748fa 158Summary(pl.UTF-8): Statycznie skonsolidowany GNU Bourne Again Shell (bash)
23ed535f 159Group: Applications/Shells
80a4c26d 160Requires: %{name} = %{version}-%{release}
4f62851f
JR
161
162%description static
001c539f 163Bash is a GNU project sh-compatible shell or command language
164interpreter. Bash (Bourne Again shell) incorporates useful features
165from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
166be run by bash without modification. Bash offers several improvements
167over sh, including command line editing, unlimited size command
168history, job control, shell functions and aliases, indexed arrays of
169unlimited size and integer arithmetic in any base from two to 64. Bash
170is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
171Shell and Tools standard. Bash is the default shell for Linux
172Mandrake. You should install bash because of its popularity and power.
2f1a3089 173You'll probably end up using it. This package contains statically
c59be5db 174linked version of bash.
4f62851f 175
ef6e8bca
JR
176%description static -l pl.UTF-8
177Bash jest zaawansowaną powłoką, która wykonuje komendy czytane ze
178standardowego wejścia (stdin) lub z pliku. Posiada właściwości powłok
179Korn i C (ksh i csh). Bash jest również zaimplementowany IEEE Posix
180Shell oraz jest zgodny ze specyfikacją - IEEE Working Group 1003.2. W
97eb1e25 181tym pakiecie jest wersja basha skonsolidowana statycznie.
4f62851f 182
67581caa 183%prep
8bd2c87f 184%setup -q -n %{name}-%{ver} -a5
e588d508 185# official patches
03cee40d 186%{?patchlevel:%patchset_patch 1 %{patchlevel}}
7d6d2b69 187%patch0 -p1
188%patch1 -p1
189%patch2 -p1
190%patch3 -p1
0e4146b6 191%patch4 -p1
6ff1ee53 192%patch5 -p1
de76156e 193%patch6 -p1
c23570b7 194%patch8 -p1
60c0b40e 195%{?with_bash_history:%patch9 -p1}
f2c0c7f0 196%patch10 -p1
232f944c 197%patch11 -p1
b92ff090 198%patch12 -p1
d6f116f1 199%patch13 -p0
4dfcefcb 200
322c0adb
AM
201sed -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
202
67581caa 203%build
80a4c26d 204cp -f /usr/share/automake/config.* support
f2c0c7f0 205%{__autoconf}
cf6e8919 206for mode in %{?with_static:static} shared; do
a3871122 207%configure \
7d6d2b69 208 --enable-alias \
209 --enable-help-builtin \
210 --enable-history \
211 --enable-job-control \
212 --enable-restricted \
67581caa 213 --enable-readline \
e301b341 214 --with-curses \
215 --enable-extended-glob \
96160a7f 216 --enable-dparen-arithmetic \
c70eed6a 217 --enable-separate-helpfiles \
2246337a 218 --without-bash-malloc \
d7465fdf 219 $([ "$mode" = "static" ] && echo "--enable-static-link") \
61e3c662 220 --with-installed-readline
31838660 221
80a4c26d
JB
222%{__make} \
223 DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
c23570b7 224
d7465fdf 225[ "$mode" = "static" ] && mv -f bash bash.static
c23570b7 226done
67581caa 227
e407816c
ER
228%{?with_tests:%{__make} tests}
229
67581caa 230%install
5b3ea703 231rm -rf $RPM_BUILD_ROOT
c70eed6a 232install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
cf6e8919 233%{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
83cdd671 234
2e52df12
PG
235%{__make} install \
236 DESTDIR=$RPM_BUILD_ROOT
7d6d2b69 237
5b3ea703 238mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
a651f1c4 239%{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
e301b341 240
5b3ea703 241install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
001c539f 242echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
243
1e516eb0 244for d in es fr it ja ko nl pl ; do
6bcdcdc6
JB
245 install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
246 install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
247 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
248done
249
7a3d4a72 250ln -sf bash $RPM_BUILD_ROOT/bin/rbash
67581caa 251
5b3ea703
TP
252install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
253install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
254install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
cd415c53 255rm -f $RPM_BUILD_ROOT%{_infodir}/dir
8f301559 256
d5597b0f
ER
257# use our bugtracker, upstream will ignore reports from this anyway
258rm -f $RPM_BUILD_ROOT%{_bindir}/bashbug
259
60c0b40e
JB
260%find_lang %{name}
261
7a3d4a72
JB
262%clean
263rm -rf $RPM_BUILD_ROOT
264
41a1b1c8
ER
265%post -p <lua>
266%lua_add_etc_shells /bin/bash /bin/rbash
b77458b2 267os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
7d6d2b69 268
41a1b1c8
ER
269%preun -p <lua>
270if arg[2] == 0 then
271 %lua_remove_etc_shells /bin/bash /bin/rbash
272end
4f62851f 273
27fc3f6e
ER
274%postun -p /sbin/postshell
275-/usr/sbin/fix-info-dir -c %{_infodir}
f358ed26 276
41a1b1c8
ER
277%post static -p <lua>
278%lua_add_etc_shells /bin/bash.static
279
280%preun static -p <lua>
281if arg[2] == 0 then
282 %lua_remove_etc_shells /bin/bash.static
283end
ee4033f9 284
60c0b40e 285%files -f %{name}.lang
7d6d2b69 286%defattr(644,root,root,755)
60c0b40e 287%doc CHANGES NEWS README doc/{FAQ,INTRO}
7d6d2b69 288
3eb3ef3a
ER
289%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
290%config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
291%config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
292%config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
7d6d2b69 293
96160a7f 294%attr(755,root,root) /bin/bash
295%attr(755,root,root) /bin/rbash
7d6d2b69 296
b26f8c7c 297%{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
dd7e7833 298%{_infodir}/bash.info*
8e2e3651 299%{_mandir}/man1/*
1e516eb0 300%lang(es) %{_mandir}/es/man1/*
6bcdcdc6
JB
301%lang(fr) %{_mandir}/fr/man1/*
302%lang(it) %{_mandir}/it/man1/*
303%lang(ja) %{_mandir}/ja/man1/*
304%lang(ko) %{_mandir}/ko/man1/*
305%lang(nl) %{_mandir}/nl/man1/*
306%lang(pl) %{_mandir}/pl/man1/*
38cd3b3d
ER
307%dir %{_datadir}/%{name}
308%doc %{_datadir}/%{name}/*
67581caa 309
a651f1c4
JB
310%if %{with static}
311%files static
312%defattr(644,root,root,755)
313%attr(755,root,root) /bin/bash.static
314%endif
This page took 0.119909 seconds and 4 git commands to generate.