]> git.pld-linux.org Git - packages/aubio.git/blame - aubio.spec
- install arch module in proper place
[packages/aubio.git] / aubio.spec
CommitLineData
79fb52b2
SS
1# TODO:
2# - unpackaged /usr/share/sounds/aubio/woodblock.aiff
8eebf965 3# - python package NFY (_aubiowrapper.a in sitescriptdir?)
1597cc87
SS
4# - create lash.spec (http://www.nongnu.org/lash) and
5# --enable-lash
34861e54 6# - package doc and create audacity-plugin
79fb52b2 7#
8eebf965
SS
8# Conditional build:
9%bcond_with python # build python bindings
10#
691d98ed
JB
11Summary: aubio - library for audio labelling
12Summary(pl.UTF-8): aubio - biblioteka do oznaczania dźwięku
79fb52b2
SS
13Name: aubio
14Version: 0.3.2
15Release: 0.1
16License: GPL v2+
17Group: Libraries
18Source0: http://aubio.piem.org/pub/%{name}-%{version}.tar.gz
19# Source0-md5: ffc3e5e4880fec67064f043252263a44
20URL: http://aubio.piem.org/
21BuildRequires: alsa-lib-devel
22BuildRequires: fftw3-single-devel
23BuildRequires: jack-audio-connection-kit-devel
24BuildRequires: libsamplerate-devel
25BuildRequires: libsndfile-devel
8eebf965
SS
26%if %{with python}
27BuildRequires: python-devel
28BuildRequires: swig-python
29%endif
79fb52b2
SS
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
691d98ed
JB
33aubio is a library for audio labelling.
34
35%description -l pl.UTF-8
36aubio to biblioteka do oznaczania dźwięku.
79fb52b2
SS
37
38%package devel
9d374366
SS
39Summary: Header files for aubio library
40Summary(pl.UTF-8): Pliki nagłówkowe biblioteki aubio
79fb52b2
SS
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43
44%description devel
45Header files for aubio library.
46
47%description devel -l pl.UTF-8
48Pliki nagłówkowe biblioteki aubio.
49
50%package static
51Summary: Static aubio library
52Summary(pl.UTF-8): Statyczna biblioteka aubio
53Group: Development/Libraries
54Requires: %{name}-devel = %{version}-%{release}
55
56%description static
57Static aubio library.
58
59%description static -l pl.UTF-8
60Statyczna biblioteka aubio.
61
b9d3858a
SS
62%package progs
63Summary: Example applications using aubio library
691d98ed
JB
64Summary(pl.UTF-8): Przykładowe programy korzystajace z biblioteki aubio
65Group: Applications/Sound
b9d3858a
SS
66Requires: %{name} = %{version}-%{release}
67
68%description progs
69A few examples of applications using aubio library:
691d98ed 70- aubioonset: outputs the onset detected.
b9d3858a
SS
71- aubionotes: uses both onset and pitch to extract symbolic music data
72 from an audio source and emit MIDI like data.
691d98ed 73- aubiocut: a Python script that takes an input sound and creates one
b9d3858a
SS
74 new sample at each detected onset or beat. The slices produced by
75 aubiocut are useful for use with a sequencer such as Hydrogen.
691d98ed
JB
76- aubiopitch: a Python script to extract pitch tracks from sound
77 files.
78
79%description progs -l pl.UTF-8
80Kilka przykładowych aplikacji korzystających z biblioteki dubio:
81- aubioonset - wypisuje wykryty początek.
82- aubionotes - wykorzystuje początek i wysokość do wyciągnięcia
83 symbolicznych danych muzycznych ze źródła dźwięku i stworzenia
84 danych typu MIDI.
85- aubiocut - skrypt Pythona pobierający dźwięk wejściowy i tworzący
86 nową próbkę dla każdego wykrytego początku lub taktu. Fragmenty
87 tworzone przez aubiocut są przydatne do wykorzystania przez
88 sekwencer, jak np. Hydrogen.
89- aubiopitch - skrypt Pythona do wyciągania ścieżek wysokości z
90 plików dźwiękowych.
b9d3858a 91
8eebf965 92%package -n python-aubio
691d98ed
JB
93Summary: aubio Python bindings
94Summary(pl.UTF-8): Wiązania Pythona do biblioteki aubio
8eebf965
SS
95Group: Libraries/Python
96Requires: %{name} = %{version}-%{release}
97
98%description -n python-aubio
691d98ed
JB
99aubio Python bindings.
100
101%description -n python-aubio -l pl.UTF-8
102Wiązania Pythona do biblioteki aubio.
8eebf965 103
79fb52b2
SS
104%prep
105%setup -q
106
107%build
108%configure \
109 --enable-alsa \
1597cc87 110 --enable-jack
79fb52b2
SS
111
112%{__make}
113
114%install
115rm -rf $RPM_BUILD_ROOT
116
117%{__make} install \
118 DESTDIR=$RPM_BUILD_ROOT
119
79fb52b2
SS
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%post -p /sbin/ldconfig
124%postun -p /sbin/ldconfig
125
126%files
127%defattr(644,root,root,755)
128%doc AUTHORS ChangeLog NEWS README THANKS TODO
79fb52b2
SS
129%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
130
131%files devel
132%defattr(644,root,root,755)
133%attr(755,root,root) %{_libdir}/lib*.so
134%{_libdir}/lib*.la
135%{_includedir}/%{name}
136%{_pkgconfigdir}/*.pc
137
138%files static
139%defattr(644,root,root,755)
140%{_libdir}/lib*.a
b9d3858a
SS
141
142%files progs
143%defattr(644,root,root,755)
8eebf965
SS
144%attr(755,root,root) %{_bindir}/aubionotes
145%attr(755,root,root) %{_bindir}/aubioonset
146%attr(755,root,root) %{_bindir}/aubiotrack
147%if %{with python}
148%attr(755,root,root) %{_bindir}/aubiocut
149%attr(755,root,root) %{_bindir}/aubiopitch
150%endif
151
152%files -n python-aubio
153%defattr(644,root,root,755)
154%{py_sitescriptdir}/aubio
This page took 0.100716 seconds and 4 git commands to generate.