]> git.pld-linux.org Git - packages/argus.git/blame - argus.spec
- initial PLD release
[packages/argus.git] / argus.spec
CommitLineData
f48b1c7c 1#
2# TODO
3# - logrotate (or argusrotate)
4# - configure without options not working
5#
6# Conditional build:
7%bcond_without tcp_wrappers # build with tcp_wrappers support
8%bcond_without sasl # build with sasl support
9#
10Summary: Real time network flow monitor
11Summary(pl.UTF-8): Monitor obciążenia sieci czasu rzeczywistego
12Name: argus
13%define _ver_major 3.0
14%define _ver_minor .0
15%define _rc .rc.40
16Version: %{_ver_major}%{_ver_minor}%{_rc}
17Release: 0.1
18License: GPL v2
19Group: Applications/Networking
20Source0: ftp://qosient.com/dev/%{name}-%{_ver_major}/%{name}-%{version}.tar.gz
21# Source0-md5: 49047be6450c6255cceb3fb9bfe3caed
22Source1: %{name}.conf
23Source2: %{name}.init
24Source3: %{name}.sysconfig
25URL: http://www.qosient.com/argus/
26BuildRequires: rpmbuild(macros) >= 1.228
27Requires(post,preun): /sbin/chkconfig
28BuildRequires: libpcap-devel
29BuildRequires: bison
30%{?with_tcp_wrappers:BuildRequires: libwrap-devel}
31%{?with_tcp_wrappers:BuildRequires: cyrus-sasl-devel}
32Provides: group(argus)
33Provides: user(argus)
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37
38%description -l pl.UTF-8
39
40%prep
41%setup -q
42
43%build
44%configure \
45 --with%{!?with_tcp_wrappers:out}-libwrap \
46 --with%{!?with_sasl:out}-sasl
47%{__make}
48
49%install
50rm -rf $RPM_BUILD_ROOT
51
52install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
53install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
54install -d $RPM_BUILD_ROOT%{_var}/log/%{name}
55
56install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/%{name}.conf
57install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
58install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
59
60touch $RPM_BUILD_ROOT%{_var}/log/%{name}/%{name}.log
61
62%{__make} install \
63 DESTDIR=$RPM_BUILD_ROOT
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%pre
69%groupadd -g 214 -r argus
70%useradd -M -o -r -u 214 -d /home/services/argus -s /bin/sh -g argus -c "argus daemon" argus
71
72%post
73/sbin/chkconfig --add %{name}
74%service %{name} restart
75
76%preun
77if [ "$1" = "0" ]; then
78 %service -q %{name} stop
79 /sbin/chkconfig --del %{name}
80fi
81
82%files
83%defattr(644,root,root,755)
84%doc CREDITS ChangeLog README doc/{CHANGES,FAQ,HOW-TO}
85%attr(755,root,root) %{_bindir}/argusbug
86%attr(755,root,root) %{_sbindir}/argus
87%attr(754,root,root) /etc/rc.d/init.d/%{name}
88%dir /etc/%{name}
89%config(noreplace) %verify(not md5 mtime size) /etc/%{name}/%{name}.conf
90%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
91%dir %{_var}/log/%{name}
92%attr(640,argus,root,) %ghost %{_var}/log/%{name}/%{name}.log
93%{_mandir}/man5/argus.conf.5.gz
94%{_mandir}/man8/argus.8.gz
This page took 0.056407 seconds and 4 git commands to generate.