]> git.pld-linux.org Git - packages/apache-mod_ntlm.git/blame - apache-mod_ntlm.spec
- first spec release - especially for us.
[packages/apache-mod_ntlm.git] / apache-mod_ntlm.spec
CommitLineData
053182d6 1%define mod_name ntlm
2Summary: This is the PAM authentication module for Apache
3Name: apache-mod_%{mod_name}
4Version: 0.3
5Release: 1
6License: GPL
7Group: Networking/Daemons
8Group(de): Netzwerkwesen/Server
9Group(pl): Sieciowe/Serwery
10Source0: http://prdownloads.sourceforge.net/modntlm/mod_%{mod_name}-%{version}.tar.gz
11Patch0: %{name}-symbol_fix.patch
12BuildRequires: /usr/sbin/apxs
13BuildRequires: apache(EAPI)-devel
14Prereq: /usr/sbin/apxs
15Requires: apache(EAPI)
16URL: http://modntlm.sourceforge.net/
17BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19%define _pkglibdir %(/usr/sbin/apxs -q LIBEXECDIR)
20
21%description
22This is an authentication module for Apache that allows you to
23authenticate HTTP clients using samba or window$-like server.
24
25%prep
26%setup -q -n mod_%{mod_name}-%{version}
27%patch -p0
28
29%build
30/usr/sbin/apxs -c mod_%{mod_name}.c -o mod_%{mod_name}.so
31
32%install
33rm -rf $RPM_BUILD_ROOT
34install -d $RPM_BUILD_ROOT%{_pkglibdir}
35
36install mod_%{mod_name}.so $RPM_BUILD_ROOT%{_pkglibdir}
37
38%post
39/usr/sbin/apxs -e -a -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
40if [ -f /var/lock/subsys/httpd ]; then
41 /etc/rc.d/init.d/httpd restart 1>&2
42fi
43
44%preun
45if [ "$1" = "0" ]; then
46 /usr/sbin/apxs -e -A -n %{mod_name} %{_pkglibdir}/mod_%{mod_name}.so 1>&2
47 if [ -f /var/lock/subsys/httpd ]; then
48 /etc/rc.d/init.d/httpd restart 1>&2
49 fi
50fi
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55%files
56%defattr(644,root,root,755)
57%attr(755,root,root) %{_pkglibdir}/*
This page took 0.0559809999999999 seconds and 4 git commands to generate.