]> git.pld-linux.org Git - packages/amarok.git/blame - amarok.spec
- added BR: kdebase-devel ; now it builds
[packages/amarok.git] / amarok.spec
CommitLineData
8d75a549 1#
948e9545 2# Conditional builds:
48801ec3 3%bcond_without arts # disable arts engine
8d75a549 4%bcond_without gstreamer # disable gstreamer
7dae3fc2 5%bcond_without xine # disable xine engine
48801ec3 6%bcond_without xmms # disable xmms wrapping
604d331d 7%bcond_with mysql # enable mysql support
d4535bda 8#
aeff1a8d 9
9a77a5a2 10%define _beta beta2
3dce540f 11Summary: A KDE audio player
12Summary(pl): Odtwarzacz audio dla KDE
13Name: amarok
aeff1a8d
SP
14Version: 1.2.%{_beta}
15Release: 0.1
3dce540f 16License: GPL
17Group: X11/Applications/Multimedia
aeff1a8d 18Source0: http://dl.sourceforge.net/amarok/%{name}-1.2-%{_beta}.tar.bz2
9a77a5a2 19# Source0-md5: 8535db7a873f0ee2e697b98135e4b60d
567ab89c 20URL: http://amarok.kde.org/
fc49b51e 21Buildrequires: alsa-lib-devel
3aa3d858 22Buildrequires: arts-qt-devel
3022f84e 23Buildrequires: automake
8d75a549 24%{?with_gstreamer:BuildRequires: gstreamer-devel >= 0.8.1}
bb9faa6b 25BuildRequires: kdebase-devel
ac33bc29 26BuildRequires: kdemultimedia-devel >= 9:3.1.93
1aff4314 27Buildrequires: libmusicbrainz-devel
add3317f 28Buildrequires: libvisual-devel >= 0.2.0
1aff4314 29Buildrequires: pcre-devel
3022f84e 30BuildRequires: rpmbuild(macros) >= 1.129
43342c86 31BuildRequires: sed >= 4.0
48801ec3 32BuildRequires: sqlite3-devel
3fd16f2f 33BuildRequires: taglib-devel >= 1.3
dd353647 34BuildRequires: unsermake >= 040511
7dae3fc2 35%{?with_xine:BuildRequires: xine-lib-devel >= 2:1.0-0.rc5.0}
604d331d 36%{?with_xmms:BuildRequires: xmms-devel}
37%{?with_mysql:BuildRequires: mysql-devel}
7dae3fc2 38#BuildRequires: kdebindings-kjsembed-devel
48801ec3 39Requires: %{name}-plugin = %{version}-%{release}
3dce540f 40Requires: kdebase-core >= 9:3.1.93
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
44A KDE audio player.
45
46%description -l pl
47Odtwarzacz audio dla KDE.
48
48801ec3 49%package arts
50Summary: Plugin arts
51Summary(pl): Wtyczka arts
52Group: X11/Applications/Multimedia
53Requires: %{name} = %{version}-%{release}
54Provides: %{name}-plugin = %{version}-%{release}
55
56%description arts
57Plugin arts.
58
59%description arts -l pl
60Wtyczka arts.
61
8d75a549 62%package gstreamer
d4535bda 63Summary: Plugin gstreamer
8d75a549 64Summary(pl): Wtyczka gstreamer
65Group: X11/Applications/Multimedia
4d1b1b41 66Requires: %{name} = %{version}-%{release}
48801ec3 67Provides: %{name}-plugin = %{version}-%{release}
8d75a549 68
69%description gstreamer
d4535bda 70Plugin gstreamer.
8d75a549 71
72%description gstreamer -l pl
73Wtyczka gstreamer.
74
7dae3fc2 75%package xine
76Summary: Plugin xine
77Summary(pl): Wtyczka xine
78Group: X11/Applications/Multimedia
1aff4314 79Requires: %{name} = %{version}-%{release}
48801ec3 80Provides: %{name}-plugin = %{version}-%{release}
7dae3fc2 81
82%description xine
83Plugin xine.
84
85%description xine -l pl
86Wtyczka xine.
87
3dce540f 88%prep
aeff1a8d 89%setup -q -n %{name}-1.2-%{_beta}
3dce540f 90
69409e85 91%{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
92 amarok/src/amarok.desktop \
93
3dce540f 94%build
4d1b1b41 95cp -f %{_datadir}/automake/config.sub admin
d3a55e61 96
4d1b1b41 97export UNSERMAKE=%{_datadir}/unsermake/unsermake
d3a55e61 98
99%{__make} -f admin/Makefile.common cvs
100
3dce540f 101%configure \
102 --disable-rpath \
48801ec3 103 %{!?with_arts:--without-arts} \
7dae3fc2 104 %{!?with_xine:--without-xine} \
105 %{!?with_gstreamer:--without-gstreamer} \
f49f397f 106 %{?with_mysql:--with-mysql} \
bb9faa6b 107 --disable-final \
f15a6325 108 --with-qt-libraries=%{_libdir} \
109 --without-included-sqlite
3dce540f 110
111%{__make}
112
113%install
114rm -rf $RPM_BUILD_ROOT
115
116%{__make} install \
117 DESTDIR=$RPM_BUILD_ROOT \
bd5fd9cb 118 kde_htmldir=%{_kdedocdir} \
119 kde_libs_htmldir=%{_kdedocdir}
43342c86 120
3248aa1e 121# remove bogus dir
122rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
123
4d1b1b41 124%find_lang amarok --all-name --with-kde
3dce540f 125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
08133359 129%files -f %{name}.lang
3dce540f 130%defattr(644,root,root,755)
8d75a549 131%doc AUTHORS ChangeLog README TODO
d4535bda 132%attr(755,root,root) %{_bindir}/amarok
3fd16f2f 133%{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
d3a55e61 134%attr(755,root,root) %{_bindir}/amarokapp
add3317f 135%attr(755,root,root) %{_bindir}/amarok_libvisual
3fd16f2f 136%attr(755,root,root) %{_bindir}/release_amarok
7dae3fc2 137%{_libdir}/kde3/libamarok_void-engine_plugin.la
138%attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
3dce540f 139%{_datadir}/apps/amarok
7dae3fc2 140%{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
d3a55e61 141%{_datadir}/config.kcfg/amarok.kcfg
7dae3fc2 142%{_datadir}/services/amarok_void-engine_plugin.desktop
d3a55e61 143%{_datadir}/servicetypes/amarok_plugin.desktop
3dce540f 144%{_desktopdir}/kde/amarok.desktop
7dae3fc2 145%{_iconsdir}/*/*/apps/amarok.png
3fd16f2f 146%{_iconsdir}/crystalsvg/*/*/player_playlist_2.png
3aa3d858 147%{_datadir}/config/*
8d75a549 148
48801ec3 149%if %{with arts}
150%files arts
151%defattr(644,root,root,755)
152%{_libdir}/kde3/libamarok_artsengine_plugin.la
153%attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
154%{_libdir}/libamarokarts.la
155%attr(755,root,root) %{_libdir}/libamarokarts.so
156%{_libdir}/mcop/Amarok
157%{_libdir}/mcop/amarokarts.mcopclass
158%{_libdir}/mcop/amarokarts.mcoptype
159%{_datadir}/services/amarok_artsengine_plugin.desktop
160%endif
161
8d75a549 162%if %{with gstreamer}
163%files gstreamer
164%defattr(644,root,root,755)
165%{_libdir}/kde3/libamarok_gstengine_plugin.la
166%attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
7dae3fc2 167%{_datadir}/config.kcfg/gstconfig.kcfg
8d75a549 168%{_datadir}/services/amarok_gstengine_plugin.desktop
169%endif
7dae3fc2 170
171%if %{with xine}
172%files xine
173%defattr(644,root,root,755)
174%{_libdir}/kde3/libamarok_xine-engine.la
175%attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
176%{_datadir}/services/amarok_xine-engine.desktop
177%{_datadir}/services/amarok_xineengine_plugin.desktop
178%endif
This page took 0.102342 seconds and 4 git commands to generate.