]> git.pld-linux.org Git - packages/amarok.git/blame - amarok.spec
- added BR: libltdl-devel
[packages/amarok.git] / amarok.spec
CommitLineData
8d75a549 1#
4fc43dcb 2# TODO:
3# * postgresql support alongside mysql
4# * NMM, MAS audio backend support
5# * make descriptions less useless
6#
948e9545 7# Conditional builds:
48801ec3 8%bcond_without arts # disable arts engine
8d75a549 9%bcond_without gstreamer # disable gstreamer
7dae3fc2 10%bcond_without xine # disable xine engine
48801ec3 11%bcond_without xmms # disable xmms wrapping
bdca4c01 12%bcond_without zeroconf # disbale suport for zeroconf
604d331d 13%bcond_with mysql # enable mysql support
d4535bda 14#
625e1885 15%define _beta beta1
3dce540f 16Summary: A KDE audio player
17Summary(pl): Odtwarzacz audio dla KDE
18Name: amarok
625e1885
SP
19Version: 1.3
20Release: 0.%{_beta}.1
3dce540f 21License: GPL
22Group: X11/Applications/Multimedia
625e1885
SP
23Source0: http://dl.sourceforge.net/amarok/%{name}-%{version}-beta1.tar.bz2
24# Source0-md5: d270fd69f58d3f4ba1c0d7ff4c520f5a
4fc43dcb 25Patch0: kde-common-gcc4.patch
567ab89c 26URL: http://amarok.kde.org/
4fc43dcb 27BuildRequires: SDL-devel
28BuildRequires: alsa-lib-devel
29BuildRequires: arts-qt-devel
30BuildRequires: automake
512f2835 31%{?with_gstreamer:BuildRequires: gstreamer-plugins-devel >= 0.8.1}
bb9faa6b 32BuildRequires: kdebase-devel
4fc43dcb 33BuildRequires: kdemultimedia-akode
ac33bc29 34BuildRequires: kdemultimedia-devel >= 9:3.1.93
acac53f1 35BuildRequires: libltdl-devel
4fc43dcb 36BuildRequires: libmusicbrainz-devel
37BuildRequires: libvisual-devel >= 0.2.0
38BuildRequires: pcre-devel
3022f84e 39BuildRequires: rpmbuild(macros) >= 1.129
43342c86 40BuildRequires: sed >= 4.0
48801ec3 41BuildRequires: sqlite3-devel
512f2835 42BuildRequires: taglib-devel >= 1.3.1
f96a59dd 43#BuildRequires: unsermake >= 040511
512f2835
SP
44%{?with_xine:BuildRequires: xine-lib-devel >= 2:1.0-0.rc5.0}
45%{?with_xmms:BuildRequires: xmms-devel}
46%{?with_mysql:BuildRequires: mysql-devel}
af820bda 47#BuildRequires: kdebindings-kjsembed-devel
48801ec3 48Requires: %{name}-plugin = %{version}-%{release}
3dce540f 49Requires: kdebase-core >= 9:3.1.93
50fa799e 50Requires: kdemultimedia-audiocd >= 9:3.1.93
3dce540f 51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
54A KDE audio player.
55
56%description -l pl
57Odtwarzacz audio dla KDE.
58
48801ec3 59%package arts
60Summary: Plugin arts
61Summary(pl): Wtyczka arts
62Group: X11/Applications/Multimedia
63Requires: %{name} = %{version}-%{release}
64Provides: %{name}-plugin = %{version}-%{release}
65
66%description arts
67Plugin arts.
68
69%description arts -l pl
70Wtyczka arts.
71
bdca4c01 72
4fc43dcb 73%package akode
625e1885
SP
74Summary: Plugin akode
75Summary(pl): Wtyczka akode
76Group: X11/Applications/Multimedia
77Requires: %{name} = %{version}-%{release}
78Provides: %{name}-plugin = %{version}-%{release}
4fc43dcb 79
80%description akode
81Plugin akode.
82
83%description akode -l pl
84Wtyczka akode.
85
86
8d75a549 87%package gstreamer
d4535bda 88Summary: Plugin gstreamer
8d75a549 89Summary(pl): Wtyczka gstreamer
90Group: X11/Applications/Multimedia
4fc43dcb 91# needed libs
625e1885 92# at least /usr/lib/gstreamer-0.8/libgstresample.so
4fc43dcb 93# probably /usr/lib/gstreamer-0.8/libgstadder.so
94# and probably /usr/lib/gstreamer-0.8/libgstvolume.so
95Requires: gstreamer-audio-effects
4d1b1b41 96Requires: %{name} = %{version}-%{release}
48801ec3 97Provides: %{name}-plugin = %{version}-%{release}
8d75a549 98
99%description gstreamer
d4535bda 100Plugin gstreamer.
8d75a549 101
102%description gstreamer -l pl
103Wtyczka gstreamer.
104
7dae3fc2 105%package xine
106Summary: Plugin xine
107Summary(pl): Wtyczka xine
108Group: X11/Applications/Multimedia
1aff4314 109Requires: %{name} = %{version}-%{release}
48801ec3 110Provides: %{name}-plugin = %{version}-%{release}
7dae3fc2 111
112%description xine
113Plugin xine.
114
115%description xine -l pl
116Wtyczka xine.
117
bdca4c01 118%package zeroconf
119Summary: Zeroconf data
120Summary(pl): Dane dla zeroconf
121Group: X11/Applications/Multimedia
122Requires: %{name} = %{version}-%{release}
123Requires: kdenetwork-kdnssd
124Provides: %{name}-plugin = %{version}-%{release}
125
126%description zeroconf
127Zeroconf data.
128
129%description zeroconf -l pl
130Zeroconf data.
131
132
3dce540f 133%prep
625e1885 134%setup -q -n %{name}-%{version}-%{_beta}
4fc43dcb 135%patch0 -p1
69409e85 136%{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
137 amarok/src/amarok.desktop \
138
3dce540f 139%build
4fc43dcb 140cp -f /usr/share/automake/config.sub admin
d3a55e61 141
4fc43dcb 142#export UNSERMAKE=/usr/share/unsermake/unsermake
d3a55e61 143
144%{__make} -f admin/Makefile.common cvs
145
3dce540f 146%configure \
147 --disable-rpath \
48801ec3 148 %{!?with_arts:--without-arts} \
7dae3fc2 149 %{!?with_xine:--without-xine} \
150 %{!?with_gstreamer:--without-gstreamer} \
f49f397f 151 %{?with_mysql:--with-mysql} \
bb9faa6b 152 --disable-final \
f15a6325 153 --with-qt-libraries=%{_libdir} \
154 --without-included-sqlite
3dce540f 155
156%{__make}
157
158%install
159rm -rf $RPM_BUILD_ROOT
160
161%{__make} install \
162 DESTDIR=$RPM_BUILD_ROOT \
bd5fd9cb 163 kde_htmldir=%{_kdedocdir} \
164 kde_libs_htmldir=%{_kdedocdir}
43342c86 165
3248aa1e 166# remove bogus dir
167rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
168
4fc43dcb 169#find_lang amarok --all-name --with-kde
3dce540f 170
171%clean
172rm -rf $RPM_BUILD_ROOT
173
af820bda
SP
174%post
175echo "Remember to install libvisual-plugins-* packages if you"
176echo "want to have a visualizations in amarok."
177
625e1885
SP
178%files
179%defattr(644,root,root,755)
bdca4c01 180# -f %{name}.lang
3dce540f 181%defattr(644,root,root,755)
380fa0f9 182%doc AUTHORS ChangeLog README TODO
d4535bda 183%attr(755,root,root) %{_bindir}/amarok
3fd16f2f 184%{?with_xmms:%attr(755,root,root) %{_bindir}/amarok_xmmswrapper2}
d3a55e61 185%attr(755,root,root) %{_bindir}/amarokapp
add3317f 186%attr(755,root,root) %{_bindir}/amarok_libvisual
4fc43dcb 187#%attr(755,root,root) %{_bindir}/release_amarok
512f2835 188%{_libdir}/kde3/konqsidebar_universalamarok.la
512f2835 189%attr(755,root,root) %{_libdir}/kde3/konqsidebar_universalamarok.so
2aaa0c03 190%{_libdir}/kde3/libamarok_void-engine_plugin.la
191%attr(755,root,root) %{_libdir}/kde3/libamarok_void-engine_plugin.so
3dce540f 192%{_datadir}/apps/amarok
7dae3fc2 193%{_datadir}/apps/konqueror/servicemenus/amarok_append.desktop
2aaa0c03 194%{_datadir}/apps/konqsidebartng/add/amarok.desktop
4fc43dcb 195%{_datadir}/apps/konqsidebartng/entries/amarok.desktop
196%{_datadir}/apps/konqsidebartng/kicker_entries/amarok.desktop
2aaa0c03 197%{_datadir}/apps/profiles/amarok.profile.xml
198%{_datadir}/config/amarokrc
d3a55e61 199%{_datadir}/config.kcfg/amarok.kcfg
7dae3fc2 200%{_datadir}/services/amarok_void-engine_plugin.desktop
d3a55e61 201%{_datadir}/servicetypes/amarok_plugin.desktop
3dce540f 202%{_desktopdir}/kde/amarok.desktop
2aaa0c03 203%{_iconsdir}/*/*/apps/amarok.*
8d75a549 204
48801ec3 205%if %{with arts}
206%files arts
207%defattr(644,root,root,755)
208%{_libdir}/kde3/libamarok_artsengine_plugin.la
209%attr(755,root,root) %{_libdir}/kde3/libamarok_artsengine_plugin.so
210%{_libdir}/libamarokarts.la
211%attr(755,root,root) %{_libdir}/libamarokarts.so
212%{_libdir}/mcop/Amarok
213%{_libdir}/mcop/amarokarts.mcopclass
214%{_libdir}/mcop/amarokarts.mcoptype
215%{_datadir}/services/amarok_artsengine_plugin.desktop
216%endif
217
4fc43dcb 218%files akode
219%defattr(644,root,root,755)
220%{_libdir}/kde3/libamarok_aKode-engine.la
221%attr(755,root,root) %{_libdir}/kde3/libamarok_aKode-engine.so
222%{_datadir}/services/amarok_aKode-engine.desktop
223
8d75a549 224%if %{with gstreamer}
225%files gstreamer
226%defattr(644,root,root,755)
227%{_libdir}/kde3/libamarok_gstengine_plugin.la
228%attr(755,root,root) %{_libdir}/kde3/libamarok_gstengine_plugin.so
7dae3fc2 229%{_datadir}/config.kcfg/gstconfig.kcfg
8d75a549 230%{_datadir}/services/amarok_gstengine_plugin.desktop
231%endif
7dae3fc2 232
233%if %{with xine}
234%files xine
235%defattr(644,root,root,755)
236%{_libdir}/kde3/libamarok_xine-engine.la
237%attr(755,root,root) %{_libdir}/kde3/libamarok_xine-engine.so
238%{_datadir}/services/amarok_xine-engine.desktop
4fc43dcb 239#%{_datadir}/services/amarok_xineengine_plugin.desktop
7dae3fc2 240%endif
bdca4c01 241
242%if %{with zeroconf}
243%files zeroconf
244%defattr(644,root,root,755)
245%{_datadir}/apps/zeroconf/_shoutcast._tcp
246%endif
This page took 0.058787 seconds and 4 git commands to generate.