]> git.pld-linux.org Git - packages/airvideo.git/blame - airvideo.spec
- up to 2.4.5 beta6, alpha6 jar
[packages/airvideo.git] / airvideo.spec
CommitLineData
246fbce2
ER
1# NOTE
2# - setup guide:
3# http://wiki.birth-online.de/know-how/hardware/apple-iphone/airvideo-server-linux
4# - clarify source files license and remove nosource
5
6%include /usr/lib/rpm/macros.java
7Summary: Air-Video Video Streaming Server
8Name: airvideo
1b0c47eb
ER
9Version: 2.4.5
10Release: 0.11
246fbce2
ER
11License: GPL v2+ with LGPL v2+ parts
12Group: Applications/Multimedia
1b0c47eb
ER
13Source0: http://inmethod.com/air-video/download/ffmpeg-for-%{version}-beta6.tar.bz2
14# NoSource0-md5: 241844e9d41bbd9f8852955291490910
246fbce2
ER
15NoSource: 0
16Source1: %{name}.init
1b0c47eb
ER
17Source2: http://inmethod.com/air-video/download/linux/alpha6/AirVideoServerLinux.jar#/avs-alpha6.jar
18# NoSource2-md5: b619c088eea230afa92181393a36e1c0
246fbce2 19NoSource: 2
fa7bf6bc 20Source3: test.properties
1b0c47eb 21Source4: avs.avahi
246fbce2 22URL: http://www.inmethod.com/air-video/
246fbce2
ER
23BuildRequires: lame-libs-devel
24BuildRequires: libx264-devel >= 0.1.3
25BuildRequires: pkgconfig
26BuildRequires: rpm-javaprov
27BuildRequires: rpmbuild(macros) >= 1.470
1b0c47eb 28Requires(post,preun): /sbin/chkconfig
246fbce2
ER
29Requires: faac
30Requires: jpackage-utils
029fd6c4 31Requires: mpeg4ip-server
246fbce2
ER
32Requires: rc-scripts
33BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35%define _noautoreqdep libGL.so.1 libGLU.so.1
36
37%define specflags -fno-strict-aliasing
38
39# -fomit-frame-pointer is always needed on x86 due to lack of registers (-fPIC takes one)
40%define specflags_ia32 -fomit-frame-pointer
41# -mmmx is needed to enable <mmintrin.h> code.
42%define specflags_i586 -mmmx
43%define specflags_i686 -mmmx
44%define specflags_ppc -fPIC
45
46%description
47Air Video can stream videos in almost any format to your iPhone, iPad
48and iPod touch. You don't need to copy your videos to the device just
49to watch them.
50
1b0c47eb
ER
51%package avahi
52Summary: airvideo service configuration for avahi
53Summary(pl.UTF-8): Konfiguracja serwisu airvideo dla avahi
54Group: Applications
55Requires: %{name} = %{version}-%{release}
56Requires: avahi
57
58%description avahi
59airvideo service configuration for avahi.
60
246fbce2
ER
61%prep
62%setup -qc
1b0c47eb 63mv ffmpeg/{*,.??*} .; rmdir ffmpeg
246fbce2
ER
64
65%build
66# notes:
67# - it's not autoconf configure
68# - --disable-debug, --disable-optimizations, tune=generic causes not to override our optflags
69
70./configure \
71 --arch=%{_target_base_arch} \
72 --prefix=%{_prefix} \
73 --libdir=%{_libdir} \
74 --shlibdir=%{_libdir} \
75 --mandir=%{_mandir} \
76 --cc="%{__cc}" \
77 --extra-cflags="-D_GNU_SOURCE=1 %{rpmcppflags} %{rpmcflags}" \
78 --extra-ldflags="%{rpmcflags} %{rpmldflags}" \
79 --disable-debug \
80 --disable-optimizations \
81 --disable-stripping \
82 --enable-pthreads \
83 --disable-shared \
84 --enable-static \
85 --enable-gpl \
86 --enable-libx264 \
87 --enable-libmp3lame \
246fbce2 88 --disable-decoder=aac \
2780439a
ER
89 --disable-indevs \
90 --disable-outdevs \
029fd6c4 91 --disable-vaapi \
246fbce2
ER
92%ifnarch %{ix86} %{x8664}
93 --disable-mmx \
94%endif
95%ifarch i386 i486
96 --disable-mmx \
97%endif
98 --enable-runtime-cpudetect
99
100%{__make}
101
102%install
103rm -rf $RPM_BUILD_ROOT
1b0c47eb 104install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_sbindir},%{_javadir},/etc/{rc.d/init.d,avahi/services},/var/lib/airvideo}
246fbce2
ER
105install -p ffmpeg $RPM_BUILD_ROOT%{_sbindir}/%{name}
106install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
107
1b0c47eb 108cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_javadir}/AirVideoServerLinux.jar
fa7bf6bc 109cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.properties
1b0c47eb 110cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/avahi/services/%{name}.service
246fbce2
ER
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post
116/sbin/chkconfig --add %{name}
117%service %{name} restart
118
119%preun
120if [ "$1" = "0" ]; then
121 %service -q %{name} stop
122 /sbin/chkconfig --del %{name}
123fi
124
125%files
126%defattr(644,root,root,755)
127%attr(755,root,root) %{_sbindir}/airvideo
128%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}.properties
129%attr(754,root,root) /etc/rc.d/init.d/%{name}
130%{_javadir}/AirVideoServerLinux.jar
1ea1c37c 131# XXX, if it really writes something, get dedicated user
1b0c47eb
ER
132%dir /var/lib/airvideo
133
134%files avahi
135%defattr(644,root,root,755)
136%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/avahi/services/%{name}.service
This page took 0.064611 seconds and 4 git commands to generate.