]> git.pld-linux.org Git - packages/acroread.git/blame - acroread.spec
- 9.3.2
[packages/acroread.git] / acroread.spec
CommitLineData
14b68627 1#
2# Conditional build:
3%bcond_with license_agreement # generates package
4#
26e61bd9 5%define base_name acroread
3353987a 6%define rel 1
0eb57bee 7Summary: Adobe Acrobat Reader
aadbc0c6
ER
8Summary(pl.UTF-8): Adobe Acrobat Reader - czytnik plików PDF
9Summary(ru.UTF-8): Программа для чтения документов в формате PDF от Adobe
10Summary(uk.UTF-8): Програма для читання документів у форматі PDF від Adobe
14b68627 11%if %{with license_agreement}
12Name: %{base_name}
13%else
14Name: %{base_name}-installer
15%endif
c3e9202d 16Version: 9.3.2
80a5eb81 17Release: %{rel}%{?with_license_agreement:wla}
81f6ad30 18Epoch: 1
ef009d9a
JB
19License: distribution restricted (http://www.adobe.com/products/acrobat/distribute.html)
20# in short:
21# - not distributable on public sites (only linking to adobe.com permitted)
22# - distribution on CD requires signing Distribution Agreement (see URL above)
94abd8dc 23Group: X11/Applications/Graphics
14b68627 24%if %{with license_agreement}
2185f2ce 25Source0: ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/%{version}/enu/AdbeRdr%{version}-1_i486linux_enu.tar.bz2
c3e9202d 26# NoSource0-md5: 57c6e2f628b34dc950f834e10f553504
ecf5969f 27NoSource: 0
e4f54b4c 28%else
0337a7fe 29Source1: http://svn.pld-linux.org/svn/license-installer/license-installer.sh
3170d06c 30# Source1-md5: 329c25f457fea66ec502b7ef70cb9ede
14b68627 31%endif
a189ca6f 32# please update @COPYSOURCES@ below if you add more Sources or Patches.
1af9d1cc 33Source2: %{base_name}.desktop
34Source3: %{base_name}.png
14f626f0 35URL: http://www.adobe.com/products/acrobat/
976c259d 36%if %{with license_agreement}
3e94b2a4 37BuildRequires: rpmbuild(macros) >= 1.357
bcaf2651 38Requires: iconv
7a2c413b 39Requires: openldap-libs < 2.5
2da3bb9c 40Requires: openldap-libs >= 2.4
26e61bd9 41%else
3170d06c 42Requires: rpm-build-macros >= 1.544
18faefb3 43Requires: rpm-build-tools >= 4.4.37
976c259d 44%endif
14f626f0 45ExclusiveArch: %{ix86}
9947ca59 46ExcludeArch: i386
aed33851 47BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
7985bc82 48
fcf3bf1c 49%define platform intellinux
22bd4e96 50%define tar0 ILINXR.TAR
fcf3bf1c 51%define tar1 COMMON.TAR
94abd8dc 52
dfbbcb35 53%define _noautostrip .*\.api
2da3bb9c 54%define _noautoprov libcrypto\.so.* libssl\.so.* libcurl\.so.* libicu.* libstdc++\.so.* libgcc_s\.so.*
7a2c413b 55%define _noautoreq %{_noautoprov} '^lib.*\.so$' '^lib.*\(VERSION\)$'
f21ac523 56
7985bc82 57%description
26e61bd9
ER
58Adobe(R) Reader(R) is free software that lets you view and print PDF
59files (Portable Document Format) on a variety of hardware and
62807d83 60operating system platforms.
7985bc82 61
e013bd4f
JR
62%description -l pl.UTF-8
63Adobe(R) Reader(R) jest darmowym oprogramowaniem umożliwiającym
64oglądanie oraz drukowanie plików PDF (Portable Document Format) na
65różnych platformach sprzętowych oraz różnych systemach operacyjnych.
7985bc82 66
e013bd4f
JR
67%description -l ru.UTF-8
68Программа для чтения документов в формате Portable Document Format
69(PDF), сгенерированных Adobe Acrobat'ом.
d44545ff 70
e013bd4f
JR
71%description -l uk.UTF-8
72Програма для читання документів у форматі Portable Document Format
73(PDF), згенерованих Adobe Acrobat'ом.
d44545ff 74
f994d3ef 75%package -n browser-plugin-%{name}
ae0ad7e9 76Summary: PDF plugin for Mozilla compatible browsers
aadbc0c6 77Summary(pl.UTF-8): Wtyczka PDF dla przeglądarek zgodnych Mozilla
2e45421f 78Group: X11/Applications
26e61bd9 79Requires: %{base_name} = %{epoch}:%{version}-%{release}
3e94b2a4 80Requires: browser-plugins >= 2.0
f994d3ef 81Obsoletes: acroread-plugin
ae0ad7e9 82Obsoletes: mozilla-plugin-acroread
2e45421f 83
f994d3ef 84%description -n browser-plugin-%{name}
62807d83 85A Mozilla plugin for displaying PDF (Portable Document Format) files.
2e45421f 86
e013bd4f
JR
87%description -n browser-plugin-%{name} -l pl.UTF-8
88Wtyczka Mozilli do wyświetlania plików PDF (Portable Document Format).
2e45421f 89
7985bc82 90%prep
14b68627 91%if %{with license_agreement}
17a8eeab 92%setup -q -c
22bd4e96 93cd AdobeReader
ea015334
AM
94tar xf %{tar0}
95tar xf %{tar1}
14b68627 96%endif
7985bc82 97
98%install
99rm -rf $RPM_BUILD_ROOT
0eb57bee 100%if %{without license_agreement}
14b68627 101install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
102
e4f54b4c
ER
103sed -e '
104 s/@BASE_NAME@/%{base_name}/g
105 s/@TARGET_CPU@/%{_target_cpu}/g
106 s-@VERSION@-%{version}-g
107 s-@RELEASE@-%{release}-g
108 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
109 s,@DATADIR@,%{_datadir}/%{base_name},g
78a918bf 110 s/@COPYSOURCES@/%{base_name}{.desktop,.png}/g
1af9d1cc 111' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
14b68627 112
113install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
14b68627 114install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
1af9d1cc 115install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
14b68627 116
117%else
3e94b2a4 118install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{base_name},%{_browserpluginsdir}} \
a7dabf0b 119 $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
7985bc82 120
c7dc1b0b 121# note: there're also AdobeReader/Adobe/Help{,Viewer}
6dc16e8f 122cd AdobeReader/Adobe/Reader9
14b68627 123cp -a Reader Resource $RPM_BUILD_ROOT%{_libdir}/%{base_name}
124awk -v INSTDIR=%{_libdir}/%{base_name}/Reader \
14f626f0
TP
125 '/^install_dir=/ {print "install_dir="INSTDIR; next} \
126 {print}' \
22bd4e96 127 bin/%{base_name} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}
3e94b2a4 128install Browser/%{platform}/* $RPM_BUILD_ROOT%{_browserpluginsdir}
1af9d1cc 129install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
130install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
22bd4e96 131
6dc16e8f 132cp -a Browser/HowTo $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/
133
3f07d2af 134rm -rf $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Patch
135
7a2c413b
JB
136ln -sf /usr/lib/liblber-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/liblber.so
137ln -sf /usr/lib/libldap-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/libldap.so
22bd4e96
AM
138ln -sf /usr/share/ssl/ca-bundle.crt $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Cert/curl-ca-bundle.crt
139
140chmod a-x $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/*.so.*
14b68627 141%endif
7985bc82 142
143%clean
144rm -rf $RPM_BUILD_ROOT
145
0eb57bee 146%if %{without license_agreement}
5d59434a 147%post
e4f54b4c 148%{_bindir}/%{base_name}.install
3e94b2a4 149%endif
ae0ad7e9 150
3e94b2a4 151%if %{with license_agreement}
152%post -n browser-plugin-%{name}
153%update_browser_plugins
ae0ad7e9 154
3e94b2a4 155%postun -n browser-plugin-%{name}
156if [ "$1" = 0 ]; then
157 %update_browser_plugins
158fi
14b68627 159%endif
160
7985bc82 161%files
162%defattr(644,root,root,755)
0eb57bee 163%if %{without license_agreement}
14b68627 164%attr(755,root,root) %{_bindir}/%{base_name}.install
165%{_datadir}/%{base_name}
166%else
78a918bf 167%doc AdobeReader/ReadMe.htm
7985bc82 168%attr(755,root,root) %{_bindir}/*
14b68627 169%dir %{_libdir}/%{base_name}
170%{_libdir}/%{base_name}/Resource
14b68627 171%dir %{_libdir}/%{base_name}/Reader
172%{_libdir}/%{base_name}/Reader/help
14b68627 173%{_libdir}/%{base_name}/Reader/AcroVersion
22bd4e96
AM
174%{_libdir}/%{base_name}/Reader/Cert
175%{_libdir}/%{base_name}/Reader/GlobalPrefs
176%{_libdir}/%{base_name}/Reader/HowTo
c7dc1b0b 177%{_libdir}/%{base_name}/Reader/IDTemplates
22bd4e96 178%{_libdir}/%{base_name}/Reader/JavaScripts
c7dc1b0b
TP
179%{_libdir}/%{base_name}/Reader/Legal
180%{_libdir}/%{base_name}/Reader/Tracker
181%{_libdir}/%{base_name}/Reader/PDFSigQFormalRep.pdf
182%{_libdir}/%{base_name}/Reader/pmd.cer
78a918bf 183%{_libdir}/%{base_name}/Reader/%{platform}/mozilla
14b68627 184%dir %{_libdir}/%{base_name}/Reader/%{platform}
714a6915 185%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins
c7dc1b0b 186%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia
43255eee 187%dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d
714a6915 188%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/SPPlugins
14b68627 189%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/bin
190%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/lib
714a6915 191%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/*.api
43255eee 192%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/*.x3d
78a918bf 193%attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia/MPP
714a6915
KK
194%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/AcroForm
195%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Annotations
c7dc1b0b 196%{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/prc
a7dabf0b 197%{_desktopdir}/acroread.desktop
8a44dca4 198%{_pixmapsdir}/*
2e45421f 199
f994d3ef 200%files -n browser-plugin-%{name}
2e45421f 201%defattr(644,root,root,755)
3e94b2a4 202%attr(755,root,root) %{_browserpluginsdir}/*
14b68627 203%endif
This page took 0.106615 seconds and 4 git commands to generate.