]> git.pld-linux.org Git - packages/Perlbal.git/blame - Perlbal.spec
- new
[packages/Perlbal.git] / Perlbal.spec
CommitLineData
8c9f6f7a 1#
2# Conditional build:
3%bcond_without autodeps # don't BR packages needed only for resolving deps
4%bcond_without tests # do not perform "make test"
5#
6%include /usr/lib/rpm/macros.perl
7Summary: Perlbal - Reverse-proxy load balancer and webserver
8#Summary(pl.UTF-8):
9Name: Perlbal
10Version: 1.59
11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-authors/id/B/BR/BRADFITZ/Perlbal-%{version}.tar.gz
16# Source0-md5: 7d098abd4434b70f13638cdff3e2383a
17Source1: perlbal.init
18Source2: perlbal.sysconfig
19Patch0: %{name}-no_use_lib.patch
20URL: http://www.danga.com/perlbal/
21Requires(post,preun): /sbin/chkconfig
22BuildRequires: rpmbuild(macros) >= 1.228
23BuildRequires: perl-devel >= 1:5.8.0
24BuildRequires: rpm-perlprov >= 4.1-13
25%if %{with autodeps} || %{with tests}
26BuildRequires: perl-BSD-Resource
27BuildRequires: perl-Danga-Socket >= 1.44
28BuildRequires: perl-Sys-Syscall
29BuildRequires: perl-libwww
30%endif
31BuildArch: noarch
32BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34%define _noautoreq 'perl(Perlbal.*)'
35
36%description
37Perlbal is a single-threaded event-based server supporting HTTP load
38balancing, web serving, and a mix of the two.
39
40One of the defining things about Perlbal is that almost everything can
41be configured or reconfigured on the fly without needing to restart
42the software. A basic configuration file containing a management
43port enables you to easily perform operations on a running instance
44of Perlbal.
45
46# %description -l pl.UTF-8
47# TODO
48
49%prep
50%setup -q
51%patch0 -p1
52
53%build
54%{__perl} Makefile.PL \
55 INSTALLDIRS=vendor
56%{__make}
57
58%{?with_tests:%{__make} test}
59
60%install
61rm -rf $RPM_BUILD_ROOT
62
63%{__make} pure_install \
64 DESTDIR=$RPM_BUILD_ROOT
65
66install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/perlbal
67install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/perlbal
68cp -r conf $RPM_BUILD_ROOT%{_sysconfdir}/perlbal
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%post
74/sbin/chkconfig --add perlbal
75%service perlbal restart
76
77%preun
78if [ "$1" = "0" ]; then
79 %service -q perlbal stop
80 /sbin/chkconfig --del perlbal
81fi
82
83%files
84%defattr(644,root,root,755)
85%doc CHANGES doc conf
86%{perl_vendorlib}/*.pm
87%{perl_vendorlib}/Perlbal/
88%attr(755,root,root) %{_bindir}/*
89%{_mandir}/man?/*
90%attr(754,root,root) /etc/rc.d/init.d/perlbal
91%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/perlbal
92%dir %{_sysconfdir}/perlbal
93%attr(740,root,root) %{_sysconfdir}/perlbal/*
This page took 0.149982 seconds and 4 git commands to generate.