]> git.pld-linux.org Git - packages/OpenIPMI.git/blame - OpenIPMI.spec
- converted to UTF-8
[packages/OpenIPMI.git] / OpenIPMI.spec
CommitLineData
a88ebc16
ER
1# TODO
2# - bad BR (version mismatch):
3# File "_mc_user.py", line 240, in ?
4# class MCUsers(gui_treelist.TreeList): AttributeError: 'module' object has no attribute 'TreeList'
5# make[4]: *** [_entity.pyc] Error 1
5ce9a439
JB
6#
7# Conditional build:
1b0573f7 8%bcond_without gui # don't build tkinter-based GUI
5ce9a439 9#
e25b096b 10Summary: IPMI abstraction layer
2756e887 11Summary(pl.UTF-8): Warstwa abstrakcji IPMI
e25b096b 12Name: OpenIPMI
4c0f5857 13Version: 2.0.10
0de31454 14Release: 2
3f33a1f3 15License: LGPL (library), GPL (ipmicmd)
e25b096b
AM
16Group: Libraries
17Source0: http://dl.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
4c0f5857 18# Source0-md5: 8f5c200c5f25c33250567eaeb685e8c0
3f33a1f3 19Patch0: %{name}-link.patch
5ce9a439 20Patch1: %{name}-python.patch
e25b096b 21URL: http://openipmi.sourceforge.net/
3f33a1f3
JB
22BuildRequires: autoconf
23BuildRequires: automake
6582d0ee 24BuildRequires: gcc >= 5:3.2
effce6a6 25BuildRequires: gdbm-devel
3c3ddf24 26BuildRequires: glib2-devel >= 2.0
3f33a1f3 27BuildRequires: libtool >= 1:1.4.2-9
e25b096b 28BuildRequires: ncurses-devel
3c3ddf24
JB
29BuildRequires: net-snmp-devel
30BuildRequires: perl-devel
31BuildRequires: pkgconfig
3f33a1f3 32BuildRequires: popt-devel
8e07c864 33BuildRequires: python-devel
1b0573f7
JB
34%{?with_gui:BuildRequires: python-tkinter}
35BuildRequires: tcl-devel
5ce9a439 36BuildRequires: rpm-pythonprov
c3f6a455 37BuildRequires: swig-perl >= 1.3.25
0340f64d 38BuildRequires: swig-python >= 1.3.25
e25b096b
AM
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
3f33a1f3 42OpenIPMI project aims to develop an open code base to allow access to
e25b096b
AM
43platform information using Intelligent Platform Management Interface
44(IPMI).
45
2756e887 46%description -l pl.UTF-8
3f33a1f3 47Celem projektu OpenIPMI jest stworzenie otwartej podstawy kodu
2756e887 48pozwalającego na dostęp do informacji o platformie pzy użyciu
3f33a1f3 49interfejsu IPMI (Intelligent Platform Management Interface -
2756e887 50interfejsu inteligentnego zarządzania platformą)
3f33a1f3 51
e25b096b
AM
52%package devel
53Summary: Development part of OpenIPMI Toolkit libraries
2756e887 54Summary(pl.UTF-8): Programistyczna cześć bibliotek OpenIPMI
e25b096b 55Group: Development/Libraries
6897ea01 56Requires: %{name} = %{version}-%{release}
e25b096b
AM
57
58%description devel
3f33a1f3
JB
59Development part of OpenIPMI libraries.
60
2756e887
JR
61%description devel -l pl.UTF-8
62Programistyczna cześć bibliotek OpenIPMI.
e25b096b
AM
63
64%package static
65Summary: Static OpenIPMI libraries
2756e887 66Summary(pl.UTF-8): Statyczne biblioteki OpenIPMI
e25b096b 67Group: Development/Libraries
6897ea01 68Requires: %{name}-devel = %{version}-%{release}
e25b096b
AM
69
70%description static
71Static OpenIPMI Toolkit libraries.
72
2756e887 73%description static -l pl.UTF-8
3f33a1f3 74Statyczne biblioteki OpenIPMI.
e25b096b 75
3c3ddf24
JB
76%package -n perl-%{name}
77Summary: Perl interface to OpenIPMI
2756e887 78Summary(pl.UTF-8): Perlowy interfejs do OpenIPMI
3c3ddf24
JB
79Group: Development/Languages/Perl
80Requires: %{name} = %{version}-%{release}
81
82%description -n perl-%{name}
83Perl interface to OpenIPMI.
84
2756e887 85%description -n perl-%{name} -l pl.UTF-8
3c3ddf24
JB
86Perlowy interfejs do OpenIPMI.
87
698af8e6 88%package -n python-%{name}
f312100c 89Summary: Python interface to OpenIPMI
2756e887 90Summary(pl.UTF-8): Pythonowy interfejs do OpenIPMI
f312100c
ER
91Group: Development/Languages/Python
92Requires: %{name} = %{version}-%{release}
5f92767c 93%pyrequires_eq python-libs
698af8e6 94
95%description -n python-%{name}
96Python interface to OpenIPMI.
97
2756e887 98%description -n perl-%{name} -l pl.UTF-8
698af8e6 99Pythonowy interfejs do OpenIPMI.
100
5ce9a439
JB
101%package gui
102Summary: OpenIPMI GUI
2756e887 103Summary(pl.UTF-8): Graficzny interfejs użytkownika do OpenIPMI
5ce9a439
JB
104Group: X11/Applications
105Requires: python-%{name} = %{version}-%{release}
1b0573f7 106Requires: python-tkinter
5ce9a439
JB
107
108%description gui
109OpenIPMI GUI.
110
2756e887
JR
111%description gui -l pl.UTF-8
112Graficzny interfejs użytkownika do OpenIPMI.
5ce9a439 113
e25b096b
AM
114%prep
115%setup -q
3f33a1f3 116%patch0 -p1
5ce9a439 117%patch1 -p1
e25b096b
AM
118
119%build
120%{__libtoolize}
121%{__aclocal}
122%{__autoconf}
123%{__automake}
3f33a1f3 124CPPFLAGS="-I/usr/include/ncurses"
5ce9a439
JB
125%configure \
126 --without-glib12 \
1b0573f7 127 %{!?with_gui:--without-tkinter}
5ce9a439
JB
128%{__make} \
129 PYTHON_INSTALL_DIR=%{py_sitedir}
e25b096b
AM
130
131%install
132rm -rf $RPM_BUILD_ROOT
133
06d50aea 134%{__make} install -j1 \
d049d417
JB
135 DESTDIR=$RPM_BUILD_ROOT \
136 PYTHON_INSTALL_DIR=%{py_sitedir}
e25b096b 137
5ce9a439
JB
138rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.{py,la,a} \
139 $RPM_BUILD_ROOT%{py_sitedir}/openipmigui/*.py
dbd75781 140
e25b096b
AM
141%clean
142rm -rf $RPM_BUILD_ROOT
143
144%post -p /sbin/ldconfig
145%postun -p /sbin/ldconfig
146
147%files
148%defattr(644,root,root,755)
e25b096b 149%doc ChangeLog FAQ README* TODO
5ce9a439
JB
150%attr(755,root,root) %{_bindir}/ipmi*
151%attr(755,root,root) %{_bindir}/openipmicmd
152%attr(755,root,root) %{_bindir}/openipmish
153%attr(755,root,root) %{_bindir}/rmcp_ping
154%attr(755,root,root) %{_bindir}/solterm
3c3ddf24
JB
155%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
156%{_mandir}/man[178]/*
e25b096b
AM
157
158%files devel
159%defattr(644,root,root,755)
160%attr(755,root,root) %{_libdir}/lib*.so
161%{_libdir}/*.la
162%{_includedir}/%{name}
b5245aff 163%{_pkgconfigdir}/*.pc
e25b096b
AM
164
165%files static
166%defattr(644,root,root,755)
167%{_libdir}/lib*.a
3c3ddf24
JB
168
169%files -n perl-%{name}
170%defattr(644,root,root,755)
171%{perl_vendorarch}/OpenIPMI.pm
172%dir %{perl_vendorarch}/auto/OpenIPMI
173%attr(755,root,root) %{perl_vendorarch}/auto/OpenIPMI/OpenIPMI.so
698af8e6 174
175%files -n python-%{name}
9fc26b0d 176%defattr(644,root,root,755)
5ce9a439
JB
177%attr(755,root,root) %{py_sitedir}/_OpenIPMI.so
178%{py_sitedir}/OpenIPMI.py[co]
179
180%if %{with gui}
181%files gui
182%defattr(644,root,root,755)
183%doc swig/python/openipmigui/TODO
184%attr(755,root,root) %{_bindir}/openipmigui
185%dir %{py_sitedir}/openipmigui
186%{py_sitedir}/openipmigui/*.py[co]
187%endif
This page took 0.109235 seconds and 4 git commands to generate.